34 Replies Latest reply on Aug 9, 2018 10:12 AM by Sanford Whiteman

    All Marketo forms (still) blocked in Firefox even after trying "solutions"

      EDIT: Looks like one actual solution here might be to get an SSL cert for our landing page domain (zozi.mktoweb.com CNAME'd as go.zozi.com) and use that URL in the loadForm call. Looks like that is possibly by contacting support: Add SSL to your Landing Pages - Marketo Docs - Product Docs I will update this part of this post if that is the solution we go with / if it solves the issue.

       

      As some of you are aware, Firefox now gives the option to enable tracking protection at all times (even outside of Private mode). Many users (like my self) choose this option while installing the browser, meaning it is on all the time. This means any request to marketo.com will be blocked by Firefox if the user has chosen that option during installation or is in Private Browsing mode. This results in Marketo forms not being loaded at all.

       

      Screen+Shot+2016-07-20+at+6.58.16+PM (1).png

       

      Firefox uses the Disconnect standard block list, which can be seen here: https://disconnect.me/trackerprotection/blocked


      I have read all the threads here on getting around FF tracking protection and am still at a dead end.

       

      When you call MktoForms2.loadForm('//app-sj16.marketo.com', ... it makes a request to the Marketo servers. This is blocked by tracking protection. Some users on here suggest using a CNAME and pointing that loadForm call at the aliased domain, like MktoForms2.loadForm('//mkto.zozi.com'... That does work, but only for an http connection (you cant use https on the CNAME unless the certificate on the Marketo end is signed for your aliased domain). If you use https, all modern browsers will stop the request via the aliased domain because it is insecure.

       

      Screen+Shot+2016-07-20+at+7.00.51+PM (1).png

       

      So, another thread suggests using your landing page domain (zozi.mktoweb.com in our case). This lets the form load in Chrome but just makes your HTTPS symbol in your URL red (bad!)

       

      Screen+Shot+2016-07-20+at+7.27.24+PM.png

       

      Firefox still blocks it completely

       

      Screen+Shot+2016-07-20+at+7.10.28+PM.png

       

      Hard to believe Marketo doesn't provide SSL for *.mktoweb.com...

       

      So, here I am left with two options. A) don't use HTTPS on my website, or B) don't use Marketo forms. Which will it be? I think that is obvious if this doesn't get resolved fairly quickly...


      How many people are effected by this?