6 Replies Latest reply on Jul 7, 2016 3:43 AM by Ellie Szunko

    Sync from Salesforce to Marketo

    Ellie Szunko

      Hi - we have some campaigns we're syncing to Marketo from SFDC  to feed into event programs.

       

      The sync has always taken place fairly quickly in the past - the Marketo checkbox is ticked in Salesforce which usually triggers the members to start showing in the Marketo program. Unfortunately, although the campaign is visible in Marketo and has been successfully linked to the event program, no members at all are showing.

       

      Any ideas what the issue could be/if we've missed a simple step or this could be an issue for support?

       

      Thanks,

      Ellie

        • Re: Sync from Salesforce to Marketo
          Chris Saporito

          We use somewhat of the same process. One thing that we found was that if we are doing any sort of large update to the database that adding members to a campaign often got delayed quite a bit. Upwards of 2-3 days. I would keep an eye on it to see if any eventually come through. How long has it been since adding them to the campaign?

          1 of 1 people found this helpful
            • Re: Sync from Salesforce to Marketo
              Ellie Szunko

              Thanks Chris - it's only been about 5 hours but as it has never been longer than about 30mins for us in the past it does seem strange. We've done some testing and added a couple of test leads to the campaign and they have been added to the Marketo program. Do you think removing the leads and re-adding them to the campaign is worth a try?

                • Re: Sync from Salesforce to Marketo
                  Chris Saporito

                  A couple of things to check before changing anything.

                  • Has there been an update that could cause a backlog in sync? (Usually if we ran a territory re-alignment we saw big delays with this.)
                  • Is the campaign name identical in both Marketo/Salesforce Campaign Sync and Salesorce?
                    • Re: Sync from Salesforce to Marketo
                      Ellie Szunko

                      Thanks Chris - unfortunately both of the above are fine.

                      We have deleted and re-added the leads in the campaign in SF and this seems to have done the trick for this one campaign but obviously need a long-term solution as there's also 3 other campaigns impacted by this that are going out this week. I've logged a ticket with support and will let you know how I get on...

                        • Re: Sync from Salesforce to Marketo
                          Josh Hill

                          How exactly are you expecting the leads to appear in Marketo?

                           

                          • Sync to Marketo=T
                          • Member of SFDC Campaign
                          • Are you syncing SFDC Campaign and program ahead of time?
                          • Are the leads not in marketo at all, or just not in the Programs?
                            • Re: Sync from Salesforce to Marketo
                              Ellie Szunko

                              Hi Josh,

                               

                              We're expecting them to appear as a member of the event program. They're synced with the status of 'sent' (our default value) and then when this is changed to 'interested' in SFDC and once the SCs are activated this is the trigger to send the first batch of invitations.

                               

                              We're doing the sync before we activate any SCs to make sure the member count is correct before anything goes live.

                               

                              Some leads may already be in Marketo, some is new data but neither are appearing in the program member count.

                               

                              Our SF admin is in the process of deleting and re-adding all leads for the 4 campaigns this week, but very strange as this has never been an issue in the past for previous event programs. We ran 10 last month, following the same process and experienced no problems.

                               

                              Thanks,

                              Ellie