1 Reply Latest reply on Jun 14, 2016 2:28 PM by Sanford Whiteman

    Recent cookie and munchkin tracking issues, are you having these issues too?

      I spoke with a few consultants and other Marketo customers about this, and wondering how many others might be experiencing this as well.  It seems like cookies and munchkin tracking are no longer working properly, or only working intermittently, on Marketo Landing Pages. Here's the current issue that has happened within the last week.

       

      Previously, if a lead filled out a form with cookies enabled and didn't have any plug ins that blocked things, if they visited another Marketo landing page, information on that form if it was tied to the lead recordwould be pre-populated, and even if they didn't convert, it would still record the additional Visit of the Web page on the activity tracking log. Recently, we have encountered that subsequent visits to other Marketo landing pages are not only not pre-populating any of the form information on a known lead, rendering any progressive profiling completely useless, but also it isn't even logging that the know lead visited the Marketo landing page. We have yet to be able to consistently recreate the experience across multiple test leads. Sometimes it does track and pre-populate and sometimes it treats it like a completely unknown lead. Since there are native Marketo landing pages, we have been able to rule out that we FUBARed something ourselves with the placement of the munckin. (At least we think/hope)

       

      I have filed a support ticket and was informed that "Landing page visits are cookied for the individual landing only. If you visit another landing page you should not see the information from a previous landing page populated." but this doesn't seem to make any sense to me as previously lead information populated from one landing page form to the next as long as the cookie wasn't cleared unless they made some kind of new change I am aware of.

       

      Just curious how many others might be having problems like this as a few people I know in the Marketo customer community have said they have noticed something funny going on since last week as well.

        • Re: Recent cookie and munchkin tracking issues, are you having these issues too?
          Sanford Whiteman

           

          I have filed a support ticket and was informed that "Landing page visits are cookied for the individual landing only. If you visit another landing page you should not see the information from a previous landing page populated." but this doesn't seem to make any sense to me as previously lead information populated from one landing page form to the next as long as the cookie wasn't cleared unless they made some kind of new change I am aware of.

          You're being given incorrect information here.  PreFill on Marketo LPs is based on the associated lead, which will persist across all pages that share the Munchkin cookie.  So provided the pages have a common parent domain (all pages on pages.example.com obviously share the same parent domain, since they have the same exact origin, but pages.example.com and pages2.example.com also share the same parent domain example.com).

           

          What you may be seeing, at least in part, is high latency in lead association on your instance or pod.  People often make the mistake of thinking that something that is usually too fast for the naked eye -- the background lead association -- is actually guaranteed to complete before the next page is rendered.

           

          Either way, you need to be able to reproduce the issue to some degree or it's never going to be solved.  If you provide a link to two of your LP URLs I can run some tests to see if PreFill is correctly working.

          3 of 3 people found this helpful