3 Replies Latest reply on Aug 21, 2013 8:54 AM by 33699

    how can drag form element into my custom div elements

      Hi Everyone,

      I create a template of landing page, i want make my page responsive. 


      In the whole page footer, header, 1 container, 3 columna. for each column(mkttxtdiv,mktpicdiv,mrkformdiv) there is a css corresponding to it.

      Header and Footer are responsive.


      but when i create a landing page based on the above template, click mktformdiv element, drag and drop the form to make the css of mrkformdiv take effect on it.
      And when i check the code of web, the form element won't located in the mrkformdiv section.

      How can i do? 
        • Re: how can drag form element into my custom div elements
          Josh Hill
          I'm not sure you can do this in Marketo right now. You should edit the template itself.

          Marketo has specific code that allows you to use the form drag and drop. When that isn't set right, it won't work.

          You could create a regular page on your site and use iframes to bring in the form or use SOAP to create your own form that uploads to marketo.
          • Re: how can drag form element into my custom div elements
            Thanks Josh, i downloaded a template from net. and upload the template into my system. 

            Drag and drop the elements from marketo into the landing page that based the template.

            i renamed my elements to "posOverride" which mean float the item to the left. it's working.

            but after change the header and footer to mine, reupload to the system. then it doesn't work.

            all the items looks located in the footer. but in fact, by checking the source, they are all in mktcontent div. the footer doesn't auto padding buttom.

            i didn't change too much.

            Why it doesn't work?!
            • Re: how can drag form element into my custom div elements
              Rose:

              I believe you're talking about my responsive template. Because this is a specific-to-you troubleshooting problem, I'll send you an email and not clog the discussion board for anyone else.


              Edward Unthank
              Marketing Operations Specialist
              Yesler