2 Replies Latest reply on Feb 28, 2013 1:46 PM by 29696

    SOAP API SyncLead always creates instead of updating leads

      Hi,

      I am going around in circles trying to make an anonymous lead known using the SOAP API.

      I can call getLead based on a cookie and retrieve the anonymous lead. But when I do a SyncLead using the same cookie, it always responds:

           (ResultSyncLead){
              leadId = 28607
              syncStatus = 
                 (SyncStatus){
                    leadId = 28607
                    status = "CREATED"
                    error = None
                 }
              leadRecord = None
            }

           As in, it creates a new lead instead of updating the anonymous lead.


           Here are my synclead params:

                (ParamsSyncLead){
                   leadRecord = 
                      (LeadRecord){
                         Id = None
                         Email = None
                         ForeignSysPersonId = None
                         ForeignSysType = 
                            (ForeignSysType){
                               value = None
                            }
                         leadAttributeList = 
                            (ArrayOfAttribute){
                               attribute[] = 
                                  (Attribute){
                                     attrName = "Email"
                                     attrType = None
                                     attrValue = "foo@example.com"
                                  },
                            }
                      }
                   returnLead = True
                   marketoCookie = "id:732-BYO-081&token:_mch-mbed.org-1360169766550-44998"
                 }

                Help! 

                Thanks,

                Dan