9 Replies Latest reply on Jan 19, 2015 8:31 AM by Megan Reed

    Primo V1 Email template - issue with call to action color

      I've used the Primo V1 email template in the past and have not had an issue with the color of the call to action banner (i.e. learn more, read more, etc), but for some reason instead of showing up in white like it has in the past, the color of the words is now in blue and looks like a hyperlink. In the past I have linked this banner, but it doesn't change the font to look like a hyperlink, but rather, keeps it in the white font. Is there a way to make it so it remains in the white font??
        • Re: Primo V1 Email template - issue with call to action color
          Robert Teplansky
          If you look in the HTML source editor, the "color" parameter in the "style" tag should have the color set as #ffffff to be white.
          • Re: Primo V1 Email template - issue with call to action color
            Rob,

            Can you explain further as there are a bunch of "style" tags in the HTML. Is there one in particular I should be looking for?
            • Re: Primo V1 Email template - issue with call to action color
              Robert Teplansky
              The call to action in the Primo template should look like this:

              <p><a style="color: #ffffff; text-decoration: none;" href="#">Call to action</a></p>

              Yours probably has changed? Does the color parameter have a different color code? Or maybe none at all?
              • Re: Primo V1 Email template - issue with call to action color
                I changed the banner color, but didn't change the font color...maybe changing the banner color is what is messing it up?
                • Re: Primo V1 Email template - issue with call to action color
                  Robert Teplansky
                  Can you paste the contents of the HTML Source for that element here? (When click on Edit and see the WYSIWYG editor, click on the HTML button to get the code.)

                  My guess is that your default color for the hyperlink is the blue. The template had code in there that was over-riding your default color for that hyperlink, and that code is now gone. I can't tell without seeing it.
                  • Re: Primo V1 Email template - issue with call to action color
                    Rob,

                    Absolutely. Here is the ribbon code:

                    <!-- Ribbon -->
                                        <table class="deviceWidth" align="center" bgcolor="#4e2664" width="100%" cellspacing="0" cellpadding="0" border="0" style="color:#ffffff; font-size:24px; line-height:16px; font-family:Arial, Helvetica, sans-serif;">
                                         <tr>
                                            <td width="14" valign="top" height="50" align="left">
                                                <img width="14" height="50" border="0" style="display:block" src="https://dl.dropboxusercontent.com/u/180082968/remail4-lArr.png" />
                                            </td>
                                            <td width="10" style="border-collapse:collapse; margin:0; padding:0; line-height:1px; font-size:1px;"> </td>
                                            <td style="text-align:center; color:#ffffff; font-size:24px; line-height:24px; font-weight:bold; font-weight:normal; text-transform:uppercase; font-family:Arial, Helvetica, sans-serif;">
                                                <div class="mktEditable" id="ribbon">
                                                    <a href="#" style="color:#ffffff; text-decoration:none;">Call to action</a>
                                                </div>
                                            </td>
                                            <td width="10" style="border-collapse:collapse; margin:0; padding:0; line-height:1px; font-size:1px;"> </td>
                                            <td width="14" valign="top" height="50" align="right">
                                                <img width="14" height="50" border="0" style="display:block" src="https://dl.dropboxusercontent.com/u/180082968/remail4-rArr.png" />
                                            </td>
                                          </tr>
                                        </table>


                    I appreciate all of your help thus far!

                    Kelly
                    • Re: Primo V1 Email template - issue with call to action color
                      Robert Teplansky
                      Kelly,

                      I'm at a loss. I pasted your Ribbon code into the Pimo V1 template on my installation and the Call To Action is white, not blue. So, I don't know if you've changed something elsewhere in the template that may be affecting the way the code is rendered by the browser. You could download the template fresh again and then update the code, piece by piece until you find out what breaks it.

                      If it's not happening on other emails using the template, then it shouldn't be something external to the template that is causing it not to render correctly.

                      Sorry I couldn't be more helpful. If you're at the Boston User Group meeting next week, let me know what happens.

                      Rob
                      • Re: Primo V1 Email template - issue with call to action color
                        Okay, I think I will take your advice regarding re-uploading the template. Hopefully that will do the trick! Thanks so much for your help!
                        • Re: Primo V1 Email template - issue with call to action color
                          Megan Reed
                          I hate to revive a really old discussion, but I am having the exact same error Kelly. Were you able to figure out what is causing the hyperlink to turn the text blue?