11 Replies Latest reply on Jan 21, 2013 10:48 AM by 14760

    Japanese characters not recognized

      Hi

      I am putting together an email in Japanese. It is fine in Marketo but when I send a test (to Outlook) it shows the whole thing like this:
      アジアã�®æ¶ˆè²»è€…ã�«ã�¨ã�£ã�¦“スーパーフルーツ”ã�ŒæŠ—酸化物ã�«ç¹‹ã�Œã‚‹ã�®ã�¯æ–°ã�—ã�„コンセプトã�§ã�‚る。å�¥åº·ã�Œè¦�求ã�™ã‚‹é…¸åŒ–防æ¢å‰¤ã�¨ã�

      It's also completey thrown our template so the email is all over the place as well.

      I know Marketo is already UTF-8 compatible.

      Can anyone help me fiz this/work around this please?

      Thanks,
      Hannah
        • Re: Japanese characters not recognized
          Cecile Maindron

               Hi Hannah,

               We are sending email in Japanese too. At first we had issues with caracters as well (a lot of ???) but now it's fine.

               We are using either Frontpage or Dreamwaver to create .html (and we make sure we have selected UTF-8 in options) and then we load html via the Email Actions > Html Tools > Replace Html


               Cécile

          • Re: Japanese characters not recognized
            Does this occur with other Outlook clients or in web mail?

            Have you tried opening the email, clicking on Actions-> Other Actions-> Encoding and selecting Japanese?
            • Re: Japanese characters not recognized
              Hi Elliot

              I've just tried that and it works if I set the encoding to Japanese (EUC). Will that show/render correctly if I send it to Japan then?

              Thanks,
              Hannah
              • Re: Japanese characters not recognized
                Although I keep getting span> at the end of sentences now...!!
                • Re: Japanese characters not recognized
                  Microsoft reccommends Japanese (JIS) as the default preferred encoding for outgoing messages for best compatibility with older email systems (http://support.microsoft.com/kb/287946), but it looks like Marketo has chosen Japanese (EUC) and I understand that EUC is used commonly in Japan. 

                  The email's header should indicate which encoding it is using.  For example the following for Japanese (JIS).
                       Content-Type: text/plain;
                       charset="iso-2022-jp"

                  I believe that most Japanese email client will have this set as the default, so you should be OK, but you may want to send a test to folks you know there and see what is happening before you blast to thousands.
                  • Re: Japanese characters not recognized
                    We're currently researching with our IT team as well as marketo issues occuring with double-byte characters as well as symbols and the like upon an email send. The information renders fine in browser views as well as marketo. There may be some linkage to our company version of outlook they are leveraging which is the cloud version of 2010. Our research is still pending...but wanted to throw this out there as well
                    • Re: Japanese characters not recognized
                      Cecile Maindron
                      BTW we are using this service to check how our emails look in any web clients etc. This is often very useful.
                      https://litmus.com/tests
                      • Re: Japanese characters not recognized
                        Thanks Janet, that's great.

                        Elliot - I've sent to some colleagues in Tokyo and it's not right for them either. However, it works if I send it to my personal hotmail and gmail accounts... It could be an internal problem with outlook, or just outlook in general!

                        I've contacted Marketo support so hopefully they can help fix it.

                        Thanks for all your helps guys and girls!!

                        Hannah
                        • Re: Japanese characters not recognized
                          If they are able to provide you a solution please let us know. As our discussion lead to then saying to work with our IT dept. Which we are continuing to investigate. It may be related to the way the settings are set up on the server we use for the cloud but that has not yet been confirmed. This is still pending. However, either way I would think that marketo would want to continue to be involved as more and more people are moving to the cloud..so there may be some additional coding to add to the email templates to help with the rendering. Thanks
                          • Re: Japanese characters not recognized
                            Hi Janet,

                            Just to let you know, it took over a week to get solved with Marketo but we got it fixed on Friday!

                            They had to swtich our server - Marketo problem.

                            Worth looking into that with Marketo if you are still having problems.

                            Thanks,
                            Hannah
                            • Re: Japanese characters not recognized
                              Thanks Hannah we received notification as well from Marketo...so far so good. Still waiting on final confirmation from all our countries but overall looks like it's resolved.