Issue

Leads recently imported cannot be found

Solution

  • Check if the example leads exist in the partition the workspace has access to. It is possible that the leads cannot be found because the workspace being checked does not have access to the partition the leads exist in.
  • Check if any of the example leads have been deleted:
    • by using the Campaign Inspector to review all of the smart campaigns that contain a Delete Lead flow action. Then check the run history of each smart campaign to see which recently ran and how many people qualified. If there is a significant amount of smart campaigns that contain a delete lead flow action, contact Marketo Support for additional assistance.
    • by checking the delete lead activities via API
  • Check if the example leads' information was changed. For example, if a lead was imported with email address "john@gmail.com" then create a smart list using "Data Value Changed" filter where "previous value" was "john@gmail.com"

Root Cause

Leads could exist in a partition that has not been searched, the details could have changed, or the leads could have been deleted.

Environment

  • Lead Database
  • List Import
  • Workspaces and Partitions
  • Smart Campaign
  • Campaign Inspector