web personalization RTP not firing when lead is known

Highlighted

web personalization RTP not firing when lead is known

Hello

We have created gated content via 2 web personalization RTPs that target the same div on the same page using 2 segments.

One RTP is an In Zone that has a form.

The second In Zone RTP has content we would like to show once the user fills out the form or is already known in Marketo.

The way we are trying to have this work is using the same In Zone div on the one page, so we don’t have to maintain 2 web pages that has other material on it.

There seems to be a real delay in the page updating to the new RTP campaign. I have not been able to nail down the timing, but it seems to be a few hours.

I see the static list that I am using for the form submission is updated right away and the RTP segment has my test email in it. But the page even when I try to refresh it will still not reload the known div version.

Does anyone know if there is a set delay for RTP campaigns to work? Or another solution. I was hoping to avoid our web team having to maintain to pages.

 

Thanks

2 REPLIES 2
Highlighted

Re: web personalization RTP not firing when lead is known

Could be a campaign overlap issue. Check this https://docs.marketo.com/display/public/DOCS/Prioritizing+Web+Campaigns

Highlighted

Re: web personalization RTP not firing when lead is known

Thanks Shashank

I tried your suggestion by setting priorities on the 2 web campaigns. 1 set at 60 and the other set at 10 but it did not help. I still don't see the page div swap in the un-gated content.