utm tracking is lost

utm tracking is lost

Hi Everyone, 
I would need some advice in UTM tracking topic
We are generating new leads via our webpage (Wordpress) with embedded marketo form. I am using UTM parameters in google campaigns, and the form setup is working because in some cases I can see the parameters. But in a lot of cases, I have the following:
- UTM parameters are not tracked (I can see only the predefined default parameters)
- In the 'original referrer field' I can see only this: https://www.google.com//
- original source info: URL: /
- original source type: Web page visit
In the meantime, when I click the very first step in the activity tab (before the form fill), I can see the UTM parameters in the query

 
 

 

What should I do to gather this information? I don't want to check them 1 by 1, it is not possible.
Thank you very much in advance
Have a nice day,

Kata

 

2 REPLIES 2
Katja_Keesom
Level 6

Re: utm tracking is lost

Hi there,

It is best practice to create a set of fields on the lead record to capture your utm tags. By adding these fields as hidden fields on your form and autofilling them with your query parameter you have them accessible on the record.

You can expand this into capturing first touch as well as last touch utm tags and concatenated utm history fields. You could even consider setting them up at program leven with Program Member Custom Fields, so you can keep track of the tags for how each person entered your program.

Hope this helps!

Re: utm tracking is lost

Thank you, I will try this!