marketo cookie not set

Highlighted
Anonymous
Not applicable

marketo cookie not set

We are noticing a weird behavior in 2 different machines. On my machine I can see the marketo cookie getting set and Marketo Forms loaded. When deploying the code to another system,  marketo cookie is not getting set even though we can see the same Munchkin script available. And there are no console errors on the browser.

Although the Marketo Forms load fine.

Any pointers on what could be going wrong or missing will be really helpful.

Thanks

Tags (2)
3 REPLIES 3
Highlighted

Re: marketo cookie not set

Hi Mohit,

Do you have DNT enabled on the browser that does not track?

To be able to go further, we need you to provide the URL of the page and the browsers you are using.

-Greg

Highlighted
Anonymous
Not applicable

Re: marketo cookie not set

Thanks for your quick response.

We are using Chrome browser and each machine has its own local url:  http://scdev2 and http://{ip address}

And my machine (scdev2) has the setting "Do Not track" checked in Chrome but I can still see marketo cookie getting set.

I think the problem may be because of IP address, it should be some local host name..I'll give that a try

Highlighted
Level 10 - Community Moderator

Re: marketo cookie not set

DNT has no direct effect on whether cookies can/will be set and sent to servers. What's important is whether the remote server uses the cookie for tracking. When a server sees the DNT header, it is supposed to discard non-critical info about the session (which is more than just cookies, since a first-party server can see all your network requests even with cookies disabled).

Your problem (as you figured out) is setting cookies when using an IP address as your hostname. You'd need to set Munchkin's domainLevel to 4 for this to work.