Why links in the email template are not properly redirected to respective URLs

Re: Why links in the email template are not properly redirected to respective URLs

Please check your inbox I have mailed you the received template. Please go through all the links and let me know if you require anything else.

Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

You need to fix your DNS entries. Luckily they had short TTLs so changes will take effect promptly.

Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

I see you fixed the DNS. Please mark my answer about DNS as Correct to aid in future searches.

Re: Why links in the email template are not properly redirected to respective URLs

Please refer below image.Capture.PNG

Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

If you refuse to provide what I asked, I cannot provide help. Not Developer Tools » Inspector. I asked for "View Original" in Gmail or comparable.

(In fact what you've shown here contradicts the first thing you said. You didn't copy the href. You copied the data-saferedirecturl.)

Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

Based on what you've shown so far, you've mixed up the DNS CNAME records that are required for Marketo LP domains and Marketo branding (click tracking) domains.

Your go.rahisystems.com is an alias for rahisystems.mktoweb.com. It should be an alias for mkto-sj220081.com.

Your click.rahisystems.com is an alias for mkto-sj220081.com. It should be an alias for rahisystems.mktoweb.com.

Reversing these will cause all visits to the branding domain to be redirected to your homepage, since the branding domain is in fact the LP server, and the fallback page for nonexistent LPs is your homepage.

Re: Why links in the email template are not properly redirected to respective URLs

As you suggested we did DNS settings. The email template that I have sent you is working properly, but email which has been sent earlier they are not working properly. They are getting redirected to the homepage. Is there any other way to fix it?

Please guide us as soon as possible.

Thank you!!!

Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

If you're seeing different results with old and new emails, here's the problem: most likely you switched the LP domain and branding (tracking) domains at some point in the Marketo UI.

Your previous DNS settings may have been "correct" for a previous domain setup.

When you opened your thread yesterday, the DNS was clearly wrong/reversed for the current domain setup, given the example email you provided.

You can't have it work for both setups, old and new, simultaneously, unless you know how to set up a reverse proxy that can switch contexts based on the URL (itself a matter of guesswork, but can work 99% of the time).

Re: Why links in the email template are not properly redirected to respective URLs

When we opened this thread yesterday, DNS settings were correct according to this document https://docs.marketo.com/display/public/DOCS/Configure+Protocols+for+Marketo but links in the email templates are not getting redirected properly and then when you suggested at that time only we switched the LP domain and branding (tracking) domains. Now we did DNS settings as it was earlier, now Still getting the same issue with the email that I have sent you. We didn't do any changes since the setup we did for the first time except for yesterday.

Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

When we opened this thread yesterday, DNS settings were correct according to this document https://docs.marketo.com/display/public/DOCS/Configure+Protocols+for+Marketo

That was absolutely not the case. Your DNS settings were and are clearly wrong.

The trackable links in the email you sent me (and also posted here) were rewritten to the domain go.rahisystems.com. That means you had go.rahisystems.com as your branding domain in the Marketo UI, but (both then and now) the DNS entry for go.rahisystems.com does not point to the tracking server, it points to the LP server (.mktoweb.com is always the LP server).

; <<>> DiG 9.11.1 <<>> go.rahisystems.com

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20214

;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:

; EDNS: version: 0, flags:; udp: 1280

;; QUESTION SECTION:

;go.rahisystems.com. IN A

;; ANSWER SECTION:

go.rahisystems.com. 120 IN CNAME rahisystems.mktoweb.com.

rahisystems.mktoweb.com. 300 IN A 192.28.156.97

If you don't understand the technical side here, that's fine, but you need a DNS and HTTP expert on (or available to) your team.