Why links in the email template are not properly redirected to respective URLs

Highlighted

Why links in the email template are not properly redirected to respective URLs

Hello Team,

I have created one email template and in that given all the links that are required and scheduled this template. After it got sent, I went through all the links and they are not properly redirecting to their respective page, they all are redirected to Home Page only.

Every link in the template they all are redirected to Home Page only even social links also.

Please help me to solve this problem.

Thank you!!!

23 REPLIES 23
Highlighted
Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

As I asked on your other thread (please delete that thread now, you could've just moved it): provide an example URL exactly as it appears in the received email.

Highlighted

Re: Why links in the email template are not properly redirected to respective URLs

Highlighted
Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

Really?

It begins with https:​//www.google.com?

Highlighted

Re: Why links in the email template are not properly redirected to respective URLs

Yes

Highlighted
Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

If you actually copied that from the raw source ("view original", etc.) of a received email, that means you entered the Google search engine as the link in your email.

Show the relevant HTML <a> tag in the Marketo email editor now.

Highlighted

Re: Why links in the email template are not properly redirected to respective URLs

Below is the source code that we have added for the links.

<div style="align: center;">

<div class="m_-6489914734443872482mktoText" id="m_-6489914734443872482text456033e86-40c8-4f19-9d41-e34ca16ecf96" align="center">

<p style="text-decoration: none;"><span style="color: #ffffff; font-family: arial,helvetica,sans-serif;"><span style="font-size: 14px;"><span style="font-size: 12px; color: #ffffff;"><a style="color: #ffffff;" href="https://www.rahisystems.com/data-center-services/audio-and-video/" target="_blank"><span style="text-decoration: underline;">A/V SERVICES</span></a>      <a style="color: #ffffff;" href="https://www.rahisystems.com/data-center-products/audio-and-video/" target="_blank"><span style="text-decoration: underline;">A/V PRODUCTS</span></a>      </span></span></span><span style="color: #ffffff;"><a style="color: #ffffff;" href="https://www.rahisystems.com/data-center-solutions/integrated-environments/productivity/" target="_blank"><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 14px;"><span style="font-size: 12px;">PRODUCTIVITY</span></span></span></a><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 14px;"><span style="font-size: 12px;"> </span></span></span></span><span style="color: #ffffff; font-family: arial,helvetica,sans-serif;"><span style="font-size: 14px;"><span style="font-size: 12px;">     <span style="text-decoration: underline;"><a style="color: #ffffff;" href="https://www.rahisystems.com/contact-us/" target="_blank" id="">CONTACT US</a></span></span></span><br /></span></p>

</div>

</div>

Highlighted
Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

And now show me a screenshot of the received HTML body (View Original in Gmail, for one example) for that same part of the email.

Again you must be looking at the source view to troubleshoot this.

Highlighted

Re: Why links in the email template are not properly redirected to respective URLs

Above code is added in the template.

Highlighted
Level 10 - Community Moderator

Re: Why links in the email template are not properly redirected to respective URLs

I don't understand your response.

Need to see the source of the received email, exactly as received. No clicks. Just a screenshot.

What you're reporting is bizarre and almost certainly resulted from user error. Have to figure out exactly what that error was.