SOLVED

Website activity is not getting logged in Marketo for some leads

Go to solution
CI-AM_MPS150720
Level 1

Website activity is not getting logged in Marketo for some leads

Hi,

 

We are running a campaign for one landing page(created in Marketo) CTA action we want to trigger the automated emails, but for some leads the activity is not getting logged into Marketo and for some leads it's getting logged as expected. We are running the campaign now on our personal email id's just to make sure every test case scenarios work before we make the actual campaign live. Any suggestions?

 

Thanks

2 ACCEPTED SOLUTIONS

Accepted Solutions
Katja_Keesom
Level 6

Re: Website activity is not getting logged in Marketo for some leads

In addition to Sanford's explanation I seem to understand you are testing with multiple email addresses. If you are doing that from one device, you need to be very aware of which record has gone through associating the cookie last, as there will be only one cookie and depending on your link clicks and form fills the cookie is associated to only one record in your database (the last record you filled out a form or clicked on a link with).

So you need to write some good test scripts where you make sure to take the right steps in sequence to test the behaviour you want to verify. It might be wise to remove cookies altogether before you start testing with a new email address.

View solution in original post

SanfordWhiteman
Level 10 - Community Moderator

Re: Website activity is not getting logged in Marketo for some leads


...we have a database in Marketo on which we have sent the emails earlier as well so for those leads also are we gonna face the same issue maybe not for every contact in our database but for some of those?


Given a large enough db, there's always a non-zero chance that some of your leads will have a cookie that's already associated with a different lead from the person who received the email.

 

And in those cases, it's the original lead that'll get the Clicked Link on Web Page. It's not possible to avoid this 100% of the time, so it's something to document and understand rather than something to "fix."

View solution in original post

15 REPLIES 15
Katja_Keesom
Level 6

Re: Website activity is not getting logged in Marketo for some leads

I'm afraid I would need a little more information to give you a decent answer. What does the process look like exactly? I assume there is a form on the landing page? Were your test records already cookied before visiting the page?

Your question is a little out of context now.

SanfordWhiteman
Level 10 - Community Moderator

Re: Website activity is not getting logged in Marketo for some leads

Like Katja said, not nearly enough info here.

 

When testing, you should use more than just your personal email addresses, by the way, but an unlimited pool of test addresses (for example, "plus addresses" as supported by GMail and some other providers — <mailbox+testinstance0001@example.com>). You need to make sure net new people can be created.

CI-AM_MPS150720
Level 1

Re: Website activity is not getting logged in Marketo for some leads

Hi Katja & Sandford,

 

Thank you for your response. So the campaign is build around one landing page wherein there are 4 CTA's and 1 Form. Based on each CTA action we are triggering a respective email for that CTA & there is one batch campaign as well which includes people who doesn't interact on any of the CTA. So ideally when someone clicked on any of the 4 CTA's that person should receive the triggered email for that CTA. But since for some leads the website activity is not getting logged the trigger campaign is not working even though that particular lead clicked on any of the CTA still that person is getting the emails according to the batch campaign(since no activity is logged) not according to their actions. I hope this gives you a clear picture.

 

Thanks,

SanfordWhiteman
Level 10 - Community Moderator

Re: Website activity is not getting logged in Marketo for some leads

Still not complete... what, exactly, is the trigger in the SC? You can show screenshots.

CI-AM_MPS150720
Level 1

Re: Website activity is not getting logged in Marketo for some leads

Hi Sandford,

 

The trigger in the SC is 'Clicks link of web page' for each CTA I have created 4 Trigger campaigns. And applied the filter in Smart list as 'Not clicked link on web page' (e.g for CTA 1 - Not clicked on CTA2, CTA3, CTA4) as we want to take the highest CTA action and send the respective email. So if anyone clicks on multiple CTA's like CTA 1 & CTA 2 that person should receive email from CTA 2 not from CTA 1. 

PFA screenshots.


Thanks,

Screenshot_2.png

Screenshot_1.png

Screenshot_3.png

SanfordWhiteman
Level 10 - Community Moderator

Re: Website activity is not getting logged in Marketo for some leads

How are you ensuring that the people clicking these links have an associated Munchkin session, instead of an anonymous session?

CI-AM_MPS150720
Level 1

Re: Website activity is not getting logged in Marketo for some leads

Are you referring to the people who are visiting it for the first time? Can you please elaborate it?

SanfordWhiteman
Level 10 - Community Moderator

Re: Website activity is not getting logged in Marketo for some leads

The only way you see activity logged to a known lead in Marketo is if (a) the person allows the Munchkin cookie and (b) the Munchkin session is associated.

 

The Munchkin session can be associated in a few ways:

  • opening a Marketo email link with the mkt_tok query param or
  • filling out a Marketo form or
  • other API-driven association (unlikely to be used in your case)

These associating actions need to occur in every browser profile independently. That is, if you open a tracked link in Safari on your iOS device, this doesn't affect a still-anonymous session on Chrome, even on that same phone.

CI-AM_MPS150720
Level 1

Re: Website activity is not getting logged in Marketo for some leads

So first every person will receives the email & CTA in the email is associated with the LP. They will redirected to the LP around which we have built the campaign. So, yeah in that case the Munchkin session is associated. The problem I am facing is for some people activity is getting logged & for some not because of which Triggered campaign is not getting executed.