Webpage Visit Scoring Campaign not Triggering

Anonymous
Not applicable

Webpage Visit Scoring Campaign not Triggering

I have a campaign set up to score leads based on visits to certain high value pages on our website.  For some reason, the campaign is not triggering as expected.  I have tried different qualifiers (webpage "is", "contains", "starts with", etc), and I have tried listing the 3 pages in different ways "http", "https", "www", "simplymeasured.com", etc.  I haven't stumbled on the right combination to get this campaign to trigger.  I've also tried opening the Multiple Value Chooser window and adding my pages from there, but our webpages are not populating in the drop down.  Any ideas?

pastedImage_0.png

14 REPLIES 14
Anonymous
Not applicable

Re: Webpage Visit Scoring Campaign not Triggering

We got it to work finally.  It wanted the "www" removed, and the "contains" qualifier.

Level 10 - Community Moderator

Re: Webpage Visit Scoring Campaign not Triggering

Make sure to post your questions to Products. A mod just moved your thread today. That's why nobody responded originally.

Glad you figured it out. The solution makes sense, because your website uses the zone apex (simplymeasured.com) as the canonical (i.e. "true" hostname of the website, steering all visitors there after their first pageview.  (In contrast to other sites who use www.example.com as the canonical host and will redirect example.com to www.example.com.)

Re: Webpage Visit Scoring Campaign not Triggering

Hi,

I have the exact same issue.

I'm trying to update scores on Marketo landing page visits, and I set a smart list similar to what is shown here. Here is mine :

pastedImage_0.png

pastedImage_1.png

Though, when I run the test I do not notice any scoring variation. Any ideas why ?

Re: Webpage Visit Scoring Campaign not Triggering

Bonjour Thomas,

The problem is probably how you entered the URLs. But as they are hidden, we cannot hep you there

-Grégoire

Re: Webpage Visit Scoring Campaign not Triggering

And also,

It's always better to open a new thread that comment on an old one. More likely to get some help.

-Greg

Level 10 - Community Moderator

Re: Webpage Visit Scoring Campaign not Triggering

If you don't provide the actual values, and link to the live URLs you're looking at, it's impossible to help.

Also, you should be looking at Activity Logs first when building such SCs. Triggers won't fire for activities that don't also appear in ActLogs with the same characteristics.

Re: Webpage Visit Scoring Campaign not Triggering

My bad, also thanks for the advice Grégoire.

Here is a sample of the links I'm using on that SC :

URLs are entered that way, without the subdomain (Web page contains...) :

  • /Memo-diametres-nominaux-CoExpert.html
  • /vehicule-checklist-coexpert.html
  • /coexpert-fr-ebook-gain-temps-chantier.html

As for the Activity Logs, I'm positive, they are definitely showing out there.

Re: Webpage Visit Scoring Campaign not Triggering

Hi Thomas,

Remove the "date of activity" constraint. You are on a trigger, it's real time. This constraint only makes sense with a"min number of time" constraint.

Have you double checked that your test leads are not members of the "Leads a exclure" smart list ?

-Greg

Re: Webpage Visit Scoring Campaign not Triggering

Grégoire,

I removed the "date of activity" constraint.

And I'm positive, my tests leads aren't members of the "Leads a exclure" SL.

Additional information on that configuration :

  • Each person can run through flow once every 1 hour(s)
  • Some of the target pages are set on robots : nofollow (but there are exceptions...)

I do have similar configurations but targeting other domains :

  • Visit key pages on www.comap.fr => Configuration is similar and it is working, I notice score variations.

I wonder if the issue is coming from the subdomain http://go.comap-group.com but that would be weird because it is only hosting our Marketo landing pages.