Webhook Response Issues

Highlighted

Webhook Response Issues

So I've got a webhook set up that use the POST command to send lead records to a partner. The partner is receiving everything just fine, but when the make an update on their end to the record (about 10-20 minutes) after they receipt the information and send a response nothing happens - I see an API call was logged and they get a "200" return code, but the lead record on our end does not get updated at all.

Thoughts? I know I'm probably missing something basic about the functionality, but any insight would be appreciated.

10 REPLIES 10
Highlighted
Anonymous
Not applicable

Re: Webhook Response Issues

Hi Conor - my first inclination is that there may be an issue with the association of the updates to the existing records. Can you verify whether or not a duplicate/new record was created by the API call?

Highlighted

Re: Webhook Response Issues

No duplicates in Marketo, and no records of merging.

Is there anything specific I need to do to make sure it finds the right lead in the Marketo instance to update?

Highlighted
Level 10 - Community Moderator

Re: Webhook Response Issues

This isn't a "webhook response" question really, if they're making a separate inbound call 20 minutes later. Webhook responses are the (synchronous) HTTP responses to webhook calls, not out-of-date traffic that might happen later. You should include an example of the exact payload they're sending.

Also, though this alone won't cause the problem, I hope their side is taking API limits into account. Generally speaking, webhooks are used instead of REST, not in addition.l

Highlighted

Re: Webhook Response Issues

I think I didn't describe it correctly - they are passing back changes through the REST endpoint url. I think the problem may be that I only gave them the base of the URL and not the full    xxxx/rest/v1/leads.json - would that be the issue?

Highlighted
Marketo Employee

Re: Webhook Response Issues

Could you explain a little bit more about what's happening here?  You mention this:

>when the make an update on their end to the record (about 10-20 minutes

Are they trying to pass back changes 10-20 minutes later?  If so, how?  Webhook responses can only be mapped back to a lead record as part of the http response to the call being made, so if they've already responded, it wouldn't be possible to respond again without the webhook being called again.

Highlighted

Re: Webhook Response Issues

I think I didn't describe it correctly - they are passing back changes through the REST endpoint url. I think the problem may be that I only gave them the base of the URL and not the full    xxxx/rest/v1/leads.json - would that be the issue?

As you might be able to tell, this is not exactly my background or strong suit.

Highlighted
Marketo Employee

Re: Webhook Response Issues

It's possible.  Have you asked your vendor if they're getting any errors, or seen any errors in your notifications?

Highlighted

Re: Webhook Response Issues

They are getting the information perfectly, and when they post back to the api, they are getting a 200 return code, indicating success.

Anyway, I feel pretty dumb about misunderstanding the webhook functionality, but like a great philosopher once said "Sucking at something is the first step to being sorta good at something."

Highlighted
Level 10 - Community Moderator

Re: Webhook Response Issues

Need more info on an exact request and response payload.

Why does it take them 20m to generate a response?