Webhook Duplicate Request Issue

Highlighted

Webhook Duplicate Request Issue

Hi Team,

I'm using webhook to invoke my api, but in few cases my api call twice & I don't see any logs for multiple call in lead activity.

Case 1:

Form submitted with valid request which call webhook (within invoking my api), included fall back string ({{some.token:default=edit me]}). Lead activity contains only one webhook call (valid input request) but api receive 2 request. i.e one with valid input (empty token are returned as empty string) & other one with input with fallback string (few empty token replaced with "edit me" string)

Case 2:

Form submitted with valid request which call webhook (within invoking my api), without fall back string in json. Lead activity contains only one webhook call (valid input request) but api receive 2 request. i.e both with valid input.

does market contains any other log information to check why it sent more than one request for single webhook call?

Thanks,

Keerthana S

2 REPLIES 2
Highlighted

Re: Webhook Duplicate Request Issue

Hi Keerthana,

I would be tempted to start by analyzing your logs and seeing the details of the incoming requests. One thing that I like to do is actually add custom headers to my webhooks so I can verify that the request actually came from a specific Marketo instance, then keep that as part of logging. This should at least tell you if Marketo is misfiring and requesting the webhook twice, or if something else is erroneously invoking it once Marketo calls the webhook.

For what it's worth, I've deployed quite a few webhooks and have yet to see two requests back-to-back, especially one with no JSON payload afterwards.

Highlighted
Level 10 - Community Moderator

Re: Webhook Duplicate Request Issue

I've seen it. It's exactly as Keerthana said, the 2 requests come in side-by-side, both from the same IP, but (as I noted on the other thread) one has the Marketo User-Agent, the other doesn't.  And one observes the datatypes and default values, the other doesn't. Only one Webhook is Called ever appears in the logs. Had a support case open but it never went anywhere, and the prob seemingly subsided.