Web Personalization Campaign error when text includes lead token?

Edward_Unthank_
Level 10

Web Personalization Campaign error when text includes lead token?

We're experimenting more and more with Web Personalization (RTP), and I'm coming up against a problem of trying to create a personalization campaign for prospects on our home page.

It's a simple replacement of a span with a first name token:

pastedImage_0.png

Here's the simple replacement I've boiled it down to:

pastedImage_2.png

Any attempt at clicking "Save" or "Launch" ends up with an error upon click:

pastedImage_1.png

Anyone gotten this to work with a lead or company token in the replacement value? I've narrowed it down to any lead/company token, regardless of other values or special characters. Pretty sure this is a bug, just want to see if others have found it or there's a fix.

- Edward

11 REPLIES 11
JD_Nelson
Champion Moderator

Re: Web Personalization Campaign error when text includes lead token?

Yes - I get the same error. I did get a notice, first, however, that stated the token was being added to my database sets and would take 24-hours to become available. I then checked my database sets and didn't see the token listed. I'm wondering if it's either tracked somewhere else, or isn't appending properly?

Have you tried again since posting this, yesterday? Maybe yours has propagated by now?

Edward_Unthank_
Level 10

Re: Web Personalization Campaign error when text includes lead token?

I've tried this multiple times, putting the fields into the system about a week ago. Still getting the error, unfortunately.

Edward_Unthank_
Level 10

Re: Web Personalization Campaign error when text includes lead token?

Have you had the chance to log a support ticket about this, JD Nelson​? I'm thinking it's a bug, but I don't have Support access on this instance.

JD_Nelson
Champion Moderator

Re: Web Personalization Campaign error when text includes lead token?

no - but I can. I was testing it for you, but definitely see the benefit in getting this working. I'll open it now and let you know what they say.

Edward_Unthank_
Level 10

Re: Web Personalization Campaign error when text includes lead token?

Thanks, JD! I owe you.

Edward

Edward_Unthank_
Level 10

Re: Web Personalization Campaign error when text includes lead token?

Hey JD, heard anything on that support ticket? I keep trying every few days and keep getting the error, even when I'm trying new combinations trying to narrow down the source of the problem.

JD_Nelson
Champion Moderator

Re: Web Personalization Campaign error when text includes lead token?

they came back saying it was included in the latest update (obviously) and that it should be working now. I quickly replied and let them know that this was why we were doing it, and that it doesn't work. No update since. I'll ping them, it's been a few days.

Edward_Unthank_
Level 10

Re: Web Personalization Campaign error when text includes lead token?

Ooph.   Thanks! I owe you a drink.

JD_Nelson
Champion Moderator

Re: Web Personalization Campaign error when text includes lead token?

Ticket has been escalated to "Product Expert" -- continue to stay tuned...