SOLVED

Using tokens in email to drop in image with a link

Go to solution
Highlighted
Level 5

Using tokens in email to drop in image with a link

Hi all,

I'm trying to tokenize an email which contains an image which has a link to a landing page. I'm finding that the image drops in, but the link isn't working.

The html I'm using is this:

<p><a href="{{my.RSVP_LP_Link}}"><img class="emailimage" src="{{my.Event_Image}}" border="0" alt="" /></a></p>

The resulting html has the URLs correctly dropped in, but the image isn't linked as it should be.

Does anyone have any ideas why this isn't working?

Thanks!

James

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 5

Re: Using tokens in email to drop in image with a link

I spent some time on a call with support and they were baffled too! It seems that the email had become corrupt somehow, as the html should have worked. The solution was to create a new email.

Bring on the weekend!

View solution in original post

4 REPLIES 4
Highlighted

Re: Using tokens in email to drop in image with a link

Hi James,

Are you using the email editor v1 or v2? Are you editing the email code ? The template? pasting the code in an editable zone?

try

<a href="http://{{my.RSVP_LP_Link}}">

and remove the "http://" from the token value.

-Greg

Highlighted
Level 5

Re: Using tokens in email to drop in image with a link

Hi Greg,

Thanks for responding.

I'm pasting the code in an editable area of the email in email editor v1. I tried removing the http:// and that didn't work either.

The strange thing is, as a test I replaced the tokens with the actual URLs and it still didn't work. I've compared the html with a previous email that did work and it's identical. So I have a feeling there has to be some sort of error here. I'm going to reach out to Marketo support to see if they can shed any light.

Will report back, but if anyone else has any ideas, all input gratefully received!

James

Highlighted

Re: Using tokens in email to drop in image with a link

At least we tried

-Greg

Highlighted
Level 5

Re: Using tokens in email to drop in image with a link

I spent some time on a call with support and they were baffled too! It seems that the email had become corrupt somehow, as the html should have worked. The solution was to create a new email.

Bring on the weekend!

View solution in original post