SOLVED

Unsubscribe link not working

Go to solution
Highlighted
Level 6

Unsubscribe link not working

our unsubscribe link is not working, we had a lead reach out to us to ask us to manually remove her from communications because she could not unsubscribe.

is this a MKTO issue or an issue with our domain?

the url is www.OURDOMAIN.com/home/unsubscribe (the url that is found at at the bottom of all MKTO emails)

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unsubscribe link not working

Malik,

I would first try to locate the forms/landing pages used for the unsubscribe to make sure they are approved and functioning. You can create a new lead in Marketo as a test and send them an email, click on the unsubscribe link in the footer, visit the unsubscribe landing page, fill out the unsubscribe form, and verify that either the form or a smart campaign moved them to true for "Unsubscribe".

View solution in original post

6 REPLIES 6
Highlighted

Re: Unsubscribe link not working

Malik,

I would first try to locate the forms/landing pages used for the unsubscribe to make sure they are approved and functioning. You can create a new lead in Marketo as a test and send them an email, click on the unsubscribe link in the footer, visit the unsubscribe landing page, fill out the unsubscribe form, and verify that either the form or a smart campaign moved them to true for "Unsubscribe".

View solution in original post

Highlighted
Marketo Employee

Re: Unsubscribe link not working

In what way is it not working?  When the person filled out the form did the submission not save on their record?  Is the page not loading or the form not submitting?  Is it working for you or only not working for that one person?

Highlighted
Champion Moderator

Re: Unsubscribe link not working

How many people have said that the unsubscribe link doesn't work? Have you tested it yourself?

Our unsub link/page/form works just fine, but occasionally people will reply via email and say it doesn't work...*shrug*

Highlighted

Re: Unsubscribe link not working

Hi Malik,

1/ the URL surely ends up with a .html

2/ If you provide us with the real URL, we can at least check that the LP is working properly, at least. That will leave the problem of the email link.

Have you read this: The comprehensive guide to setting up the unsubscribe link ?

-Greg

Highlighted
Level 6

Re: Unsubscribe link not working

hey guys, looks like the Landing Page that hosted the unsubscribed form was down on Sitecore - so it was not a MKTO issue.

but thanks for all the lovely feedback, super helpful

Highlighted

Re: Unsubscribe link not working

Hi Malik,

Is this page containing a Marketo form? If not, make really sure the data syncs with Marketo, because there are legal obligations here.

-Greg