Unsubscribe Issues with Form Pre-Fill

Highlighted
Anonymous
Not applicable

Unsubscribe Issues with Form Pre-Fill

We recently ran into difficulties with people being unable to unsubscribe no matter how many times they tried to fill out the Unsubscribe form. It turned out that the cause was that the Pre-fill option was enabled in the form, which continuously defaulted to the person's original status as being Subscribed. This is not something that we knew about before, obviously, but think it's imperative to understand before setting up an Unsubscribe form.

Can you please explain why this is such an issue when it comes to setting up an Unsubscribe form and also if there are plans to add a Warning of some kind letting people know not to enable the Pre-fill option when setting up an Unsubscribe form?

Thanks,

Laura
6 REPLIES 6
Highlighted
Level 10 - Champion Alumni

Re: Unsubscribe Issues with Form Pre-Fill

The form creation is up to you. You can turn prefill off at the form or field level. this is well documented in the form instructions.

Since I can't see your form or the back end, I am unsure why prefill would cause this isuse. I have done this before with prefill and it has worked well. The lead comes in, sees their current settings and changes them. If you hid one of the fields, that could be one cause.

The only time I have had issues with prefill and subscription management is when the lead clicks on the link and sees someone else's info (forwarded email or something). This can be handled by either  not using prefill or by having a link to a special "Not You?" form that clears out the info.

Highlighted
Anonymous
Not applicable

Re: Unsubscribe Issues with Form Pre-Fill

Hi Josh,

Thanks for your response. I think it might have been that the field was hidden at the same time. It was something I had no idea would be problematic at the time, but luckily a Marketo rep was able to get to the bottom of it.

One more question, have you ever seen issues with readers being able to open the Unsubscribe link? We have been getting quite a few of these emails lately with people saying they can't open the link. Wondering if this could have anything to do with each person's email service provider (gmail vs. yahoo vs. hotmail, etc.). It's not something I've been able to duplicate when testing emails.

Thanks again,

Laura

Highlighted

Re: Unsubscribe Issues with Form Pre-Fill

This is so bizarre but I had the same issue. Per your note I disabled the pre-fill and it started working. I still don't get why, but oh well.

Highlighted
Level 7

Re: Unsubscribe Issues with Form Pre-Fill

Because pre-fill is on, Marketo will look up the current value of unsubscribed (which will be 'unchecked') in the database and will load the form with the checkbox unchecked and when a person submits the form, they're not unsubscribing from anything.

Another way of explaining it, if you have the unsubscribe checkbox hidden and pre-fill on, people can't change the field from 'unchecked' (automatically loaded) to 'checked'.

Highlighted

Re: Unsubscribe Issues with Form Pre-Fill

Well that makes so much sense it's silly:) Thanks for the explaination!!

Highlighted
Level 7

Re: Unsubscribe Issues with Form Pre-Fill

Hi, without seeing the actual email template/draft in your Marketo one can only guess. It definitely would not be because of hotmail/gmail/yahoo as Marketo compiles the HTML email before it's sent.

Just wondering how you have included the unsubscribe link in your email? <a href="http://{{system.unsubscribeLink}}"> doesn't work, <a href="{{system.unsubscribeLink}}"> works

There could be numerous other causes though