Unexpected behavior with GoToWebinar integration

Highlighted

Unexpected behavior with GoToWebinar integration

We recently implemented the integration between Marketo and our GoToWebinar account.  The registration pages for our webinar events are now built in Marketo, but everything else -- confirmation emails, reminder emails, follow-up emails, etc. -- continues to deploy from GoToWebinar, as it did before the integration.  

 

I've built out my form and registration page as well as a Smart List > Trigger=Fills Out Form > Flow=Change Program Status where New Status is Webinar >Registered, and people who register for our webinars are making it into GoToWebinar as expected, yay.  

 

However, ever since the integration, a lot of people are no longer receiving the confirmation/reminder/follow-up emails from GoToWebinar and cannot actually attend our webinars.  Nothing changed for them, except we did the integration.  And it's still working just fine for a lot of other people, so it's a complete mystery to me what's going on. 

 

GoToWebinar directed me to Marketo Support so I'm opening a case with them too, but I'm curious -- has anyone else had this experience?  We don't want to do any webinar emails through Marketo because we host daily webinars and it would take a lot of extra work to put those together, while GoToWebinar is pretty turnkey in this regard.  We only did the integration because we needed more flexibility on the registration page form (specifically to add an optional email signup to comply with CCPA without gating our webinars).  

1 REPLY 1
Highlighted

Re: Unexpected behavior with GoToWebinar integration

I don't see how Marketo should be responsible here. If your registrants enter GoToWebinar, and don't receive the confirmation from GoToWebinar although you have ticked the box that GTW should send these confirmations, I think this is clearly a GoToWebinar issue. But actually I have never experienced such behavior in many years working with this integration.

 

Are you sure that all registrants in your Marketo program have made it into GoToWebinar? Have you checked on the program status "Registration Error"? I recommend not syncing Job Title and Company Name to GTW btw, as that only opens up more room for error with regards to rejected special characters.