Unable to send a sample email

Highlighted
Level 10 - Community Moderator

Re: Unable to send a sample email

You need to ensure that there is an address that does not filter emails, otherwise you will go around and around trying to see if the email was correctly assembled and routed at the basic SMTP level.

I don't advise whitelisting Marketo email: this will merely disguise real-world deliverability problems. But you must have a way to verify that emails are going out. Have your IT create an unfiltered mailbox for you.

Highlighted

Re: Unable to send a sample email

  • What do you have for "From Email Address"?
  • Do you use tokens for the From Email Address or for the subject line?

If you could post a screenshot, it could help us troubleshoot.

Highlighted
Level 7

Re: Unable to send a sample email

Try actually sending the email to yourself and seeing the result in the smart campaign if it says email delivered or if there's a bounced reason. You'll need to add yourself to the database

Highlighted
Anonymous
Not applicable

Re: Unable to send a sample email

Hi Christine. The first thing that comes to my mind since your team is using it for the first time is: Have you selected a Person from your database in the Sample selection when you add the details in the Send Sample Email popup? Meaning that in the field Person, you should have someone who's an existing contact in your database. Then in Send to you add your personal email. The system won't just recognize a random personal email to send the sample.

Hope this helps.

Highlighted

Re: Unable to send a sample email

Hi Christine, just wondering whether you have setup DKIM and SPF, and using the from address to send your email with the same domain of your DKIM and SPF?

We found the same issue where we never received sample emails. The email's from address was using a different domain from the SPF setup.

This is because most of the public web email clients like gmail started to reject email sent without SPF. If you have not setup your SPF or you are using a different domain for from address from your SPF, your sample email is most likely get rejected, thus, bounced.

Hope this helps.

Kind regards
Stephanie
Highlighted
Level 10 - Community Moderator

Re: Unable to send a sample email

Let's not get ahead of ourselves -- SPF is only relevant if you have the branded sender domain add-on to a Marketo subscription (which is included if you have a dedicated instance, but not if you have a basic shared instance).

SPF checks the RFC 821 envelope sender domain, not the RFC 822 From: domain in the email headers.

You can read more here: https://blog.teknkl.com/your-marketo-spf-entry-doesnt-matter-unless-youre-paying-extra/

Highlighted

Re: Unable to send a sample email

Unfortunately, we tested using smart campaign flow step send email and received a bounce back from gmail with bounced reason Control unauthenticated mail from your domain - Gmail Help.

We tried it for yahoo, aol and hotmail - same result and same reason.

We then use the from address with the domain of the SPF and all of those personal emails received it.

From the look of it, they require SPF to be setup.

Kind regards
Stephanie
Highlighted
Level 10 - Community Moderator

Re: Unable to send a sample email

No, SPF only pertains to the envelope sender domain.

The From: domain is not being verified using SPF. There's no wiggle room on this -- it's simply not happening. DKIM can assist in verifying/non-repudiating From: (and other) headers.

You can learn more about how SPF does and doesn't work in these posts: https://blog.teknkl.com/tag/spf

Highlighted

Re: Unable to send a sample email

I had this same issue this week where a from address was a token. Once I changed the from email address to a general email working address, the sample went through.  Perhaps that is your issue as well?

Highlighted

Re: Unable to send a sample email

Tara brings up a good point - which we've experienced ourselves.


There's a chance there're character codes hidden at the design view for w/e tokens you're using. Unfortunately, MKTO doesn't seem to throw an error when tokens are unable to parse and as a result, no error notification & no email is sent.

I suggest using the token function in either the WYSIWYG or From, Reply-to, or subject lines if you haven't already. Also remember to address any tokens in the txt version - un-parsable tokens in txt will cause the same issue.