UTM Parameters as Hidden Fields - not coming through

Kate_Hahn1
Level 1

UTM Parameters as Hidden Fields - not coming through

I included hidden fields to capture utm parameters for forms within Marketo landing pages that we're driving traffic to through paid search. But, I'm getting quite a few blank sources coming through. Anyone know why that may be?

I'm also receiving quite a few default ("no source", as an example). Thoughts on what % of overall form fills I should expect to see blank and default values?

Thanks!

Kate

7 REPLIES 7
Anonymous
Not applicable

Re: UTM Parameters as Hidden Fields - not coming through

Can you post a view from your form editor where we can see the values of the parameter you set? This should work ok, I haven't had any issues over the past few years.

Grégoire_Miche2
Level 10

Re: UTM Parameters as Hidden Fields - not coming through

Hi Kate,

Are you sure you are using URL parameters for the source of the utm fields ? (and not a default value, a cookie, or a referrer) ?

-Greg

Josh_Hill13
Level 10 - Champion Alumni

Re: UTM Parameters as Hidden Fields - not coming through

also make sure you disable prefill on all hidden fields.

Iryna_Zhuravel4
Level 6 - Champion Alumni

Re: UTM Parameters as Hidden Fields - not coming through

If most of your leads come in with utm parameters, then your form works fine. If most or more than 50% come in blank/no source you need to troubleshoot, check suggestions from Greg and Josh above, if that doesn't help post a screenshot of your form set up.

In our org around 10-20% of leads from media campaigns come in with no utm data, this is normal and is happening due to one of the reasons below:

1. They use some  kind of adblock - according to recent studies from 10 to 30% of internet users use some kind of adblocking software, some of the adblocks can remove tracking from links (in fact we recently found one that blocks Marketo forms and munchkin )

2. They found your page organically

3. They click around before they fill in the form - when you get your utm parameters from the url, a following scenario is quite likely - a person clicks on your ad ->wants to read more about your company and goes to other pages of your site -> utm parameters in the url are lost at this point -> s/he comes back to your landing page sometime after and fills in the form -> a lead comes in with no utms. To test this run a report to see how many folks who filled in your form visited a page with the utm parameters you are trying to capture in the past 30 days

Not much we can do about 1 and 2; to avid loss of data due to reason 3  we use persistent cookie and all our forms get utm parameters from cookie values not url parameters, you'll need your developers to add some JS to your pages for this to work, see this thread for more details UTM vs Marketo Cookie: Need Clarification

SanfordWhiteman
Level 10 - Community Moderator

Re: UTM Parameters as Hidden Fields - not coming through

1. They use some kind of adblock - according to recent studies from 10 to 30% of internet users use some kind of adblocking software, some of the adblocks can remove tracking from links (in fact we recently found one that blocks Marketo forms and munchkin )

Not much we can do about 1

There are some things you can do about [1]. 

First, if ad blockers are removing utm_* query parameters, you can switch to whatever parameter names you want.  There is no functionality that is specific to this naming convention, especially for Marketo, but even for GA.  No ad blocker is going to remove arbitrary query parameters, as this breaks the browsing experience beyond repair.  Trying to browse without any query strings makes no sense.

Second, if Munchkin and/or the Forms 2.0 library are being blocked, you can load them from a hostname that's under your domain, like one of your LP domains or an in-house server.  Same with the tracking pixel itself.  But it's true that after taking a few of the simpler measures, you enter the realm of diminishing returns.  Plus, angling to track leads who don't want to be tracked is unethical: I would only recommend these measures if you believe in good faith that the lead didn't mean to block Marketo, but a blocking list accidentally includes Marketo-owned domains.  This is most certainly the case when Forms 2.0 gets onto one of these lists: forms are not privacy intrusions, trackers, or ads.

Anonymous
Not applicable

Re: UTM Parameters as Hidden Fields - not coming through

This is what I am trying to do. Can you post a picture of what your hidden fields look like or tell me what you put in the form? I really appreciate it.

Mark_Dudek1
Level 1

Re: UTM Parameters as Hidden Fields - not coming through

Another, simpler issue you may be running into (and you may want to double check) is that you are minding the case sensitivity of URL parameters. If you are looking for "UTM_Campaign" in your flow, but have "utm_campaign" in the URL, it won't work.