Twilio

Luis_Esquivel1
Level 1

Twilio

Hey Marketo-ers,

Is anyone successfully sending out SMS messages with Twilio? I cannot seem to get the webhook to trigger a send. The webhook is firing as needed and, when testing only within Twilio, I am able to get a message through. It seems the trouble is in the call itself. I'm using the following format:

//POST to URL (replacing with acctual info):

https://{{Account Id}}:{{Token}}@api.twilio.com/2010-04-01/Accounts/{{Account Id}}/Messages

//Set Header:

Form/Url

//Set Payload:

To=%2B1{{lead.Mobile}}&From=%2B1{{My number}}&Body=Test+from+Twilio

Any guidance would be appreciated!

9 REPLIES 9
Josh_Hill13
Level 10 - Champion Alumni

Re: Twilio

Does the log entry confirm a 200 response?

What does it say on Twilio's side?

Have you asked Twilio to review your webhook?

Chris_Morris1
Level 3

Re: Twilio

I've run into the same issue. I reached out to Twilio, this was the response:

Sandy Huie (Twilio)

Oct 13, 6:05 PM PDT

Hi Chris,

Thanks for writing in to Twilio Support.

The 21605 error is for too many characters. Marketo is using our deprecated /SMS/Messages Resource in their code. They need to update to our /Messages Resource in order for you to take advantage of all the benefits. One of which is concatenated message bodies with up to 1600 characters.

Here is our FAQ on the benefits of updating:

https://support.twilio.com/hc/en-us/articles/223181028-Switching-from-SMS-Messages-resource-URI-to-M...

If you would like to take advantage of these benefits, I would suggest contacting Marketo to have them update their code.

Hope this helps. Please let me know if I can be of further assistance.

Best regards,

Sandy

Twilio Support

Office Hours: Monday-Friday 9-6pm PST

Is anyone successfully using Twilio via Marketo at the moment?

Luis_Esquivel1
Level 1

Re: Twilio

Response code 1000

I reached out to support and got some documentation in return, but no success.

I believe I'm using the latest /Messages resource.

I'll keep trying and will post updates.

Diego_Lineros2
Level 5

Re: Twilio

Capturesms.PNG

This one is currently working for me

Josh_Hill13
Level 10 - Champion Alumni

Re: Twilio

That's a weird response. Their BD and Product people should call Marketo's to fix the development.

Diego_Lineros2
Level 5

Re: Twilio

What is weird?

Josh_Hill13
Level 10 - Champion Alumni

Re: Twilio

Twilio's response to you.

Luis_Esquivel1
Level 1

Re: Twilio

It seems it was a simple slip up on my part. Response code 1000 is Marketo saying that the Webhook is being called with a batch campaign vs the required triggered. I set up campaign pair with a request campaign flow and campaign requested trigger and it worked. Thanks for the feedback everybody!

Chris_Morris1
Level 3

Re: Twilio

I've been going back and forth between Marketo Support and Twilio Support for the past few days.

Twilio states Marketo needs to update code, while Marketo states as long as the URL used in the webhook is up to date, all is good.

I went back to Twilio to confirm the URL I have is current (I pulled it from documentation in this Community). Twilio support advised me to remove the 'SMS' from the URL.

I made this change, and my initial test worked  - I can send texts via Twilio/Marketo webhook integration again.

Hope this helps someone.