Tracking not work properly

Highlighted
Level 2

Tracking not work properly

Hi all,

I have a problem with marketo tracking, maybe some of you can help me to understand how to fix the problem.

I have created a program in which I have sync a SF database, then I have created an email in marketo and this email redirect to an external Lp in which I have put the Munchkin code to track all the activities. In this external lp is present a form.

All the activities done on the email are tracked correctly, while the activities on the lp are visible only after people fill in the form. This is a big problem for us because no actions result visible.

People who click on the lp are all known visitor so I expect they are recognize.

Do you have some suggestion to fix this issue?

Many thanks!

Margherita

5 REPLIES 5
Highlighted
Level 10 - Community Moderator

Re: Tracking not work properly

Do you have Include mkt_tok enabled on your email links? It's critical to have mkt_tok if you want Munchkin to automatically associate web sessions that result from email clicks. If you provide one of the links from an email (the rewritten link at your tracking domain, that is, the link as it appears in the sent email) I can look at it for you.

Highlighted
Level 2

Re: Tracking not work properly

Hi Sanford!

The main problem is that people who click were not recognize, because I have some results in my smart campaign which track click of people, but only after they have filled in the form.

Here the link of the Lp is: http://mkto-lon030058.com/ol/j0lVeMDLIlxQsRp1-fmYNqDikTTHf5arorV_BNXjxs49zFtqP76fbxW_xZ4cT8NjN7HTERA...

Many thanks!

Margherita

Highlighted
Level 10 - Community Moderator

Re: Tracking not work properly

You can't use Bitly links like this, since they will strip the dynamic mkt_tok query param that's critical to pass to your site. (This is not a Marketo problem, it's a Bitly missing feature/problem.)

You have to use a link shortener that forwards query strings to the destination. Bitly's Pro Edition might do this -- you have to verify. I know ProBudUrl does it, for one example.

Highlighted
Level 2

Re: Tracking not work properly

Thanks for your suggestion!

However I have also other CTA in this email, without bitly and these do not work as for the one that I have show you.

If you have any other idea please share with me!

Many thanks

Margherita

Highlighted
Level 10 - Community Moderator

Re: Tracking not work properly

It's not merely a "suggestion," it's the correct answer for that link. It's 100% clear that the first redirect is to Bitly with the mkt_tok, then Bitly strips it off so your site doesn't see it.

If you have other links that end up on your site without the mkt_tok, I presume they're also bouncing off a server that strips the query string. Either that or you're taking people directly to downloadable assets, which is a bad idea. (Assets like PDFs can't associate sessions.) If you post another link I'll tell you what's wrong w/that one, too.