SOLVED

Trackable Link Not Working

Go to solution
Highlighted
Level 7 - Champion

Trackable Link Not Working

Hi, all!

Anyone else having issues with trackable links not working? I have this one particular link that when I visit it directly, it works fine, but as soon as it's tracked in an email, I get a blank white screen.

Wanted to see if it was only me

Thanks!
Jenn

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Community Moderator

Re: Trackable Link Not Working

BTW for anyone lurking the problem with Jenn's link is that it's too long -- for her server, not for Marketo -- once the tracking token is appended. The tracking part works and redirects, but then her server says it can't load the URL.

This is really her webserver being misconfigured, since the URL is still short. I assume it has a really low limit of 256 characters!

An immediate fix is to turn off mkt_tok, ​although that's destructive because it means web sessions won't be associated. I'll be sending Jenn another workaround and if you're curious you could ping me as well.

View solution in original post

7 REPLIES 7
Highlighted
Level 10 - Community Moderator

Re: Trackable Link Not Working

Doubt it's the tracking server itself. If you post the link (the rewritten link @ your tracking domain) I'll tell you what's happening.

Highlighted
Level 7 - Champion

Re: Trackable Link Not Working

Thanks, Sanford! I'll send it to your inbox

Highlighted
Level 10 - Community Moderator

Re: Trackable Link Not Working

BTW for anyone lurking the problem with Jenn's link is that it's too long -- for her server, not for Marketo -- once the tracking token is appended. The tracking part works and redirects, but then her server says it can't load the URL.

This is really her webserver being misconfigured, since the URL is still short. I assume it has a really low limit of 256 characters!

An immediate fix is to turn off mkt_tok, ​although that's destructive because it means web sessions won't be associated. I'll be sending Jenn another workaround and if you're curious you could ping me as well.

View solution in original post

Highlighted
Anonymous
Not applicable

Re: Trackable Link Not Working

Hi Sanford,

I appreciate the investigation. I'm having a similar issue with a few links in an email not working when the mkt_tok function is enabled. Considering the importance of this tracking, were you able to figure out another workaround?

Moreover, the links seemed to be working fine a couple days ago. No changes were made to the email since then. Any idea as to why and how this link error occurred?

Highlighted
Level 10 - Community Moderator

Re: Trackable Link Not Working

Can you open a new thread and link back to this one?

Also, we'll need sample non-working URLS.

Highlighted
Anonymous
Not applicable

Re: Trackable Link Not Working

This just happened to me today. All emails I've sent just fine historically are now going to a page that says

This site can’t be reached

I'm at a loss. We have been sending emails fine even earlier today, and now I'm sending test emails with Open Tracking enabled, and it's broken. But if I disable Open Tracking, it works fine. The link I'm specifically referring to right now is

http://go.hostway.com/dc/ecNrIjor46_VSHPSuTG620kqh2fjgCEELEJhr3Qf6-Lj1pLwMGXLBB-O9Jp4w0A3tZ4zI5OILvR...

All the broken ones have the same format, I just don't know how to fix it. I have an open case with Marketo since this is pretty urgent and is affecting tests on old emails I've sent in the past, regardless of the link destination. But maybe it's something easy I changed?

Highlighted
Level 10 - Community Moderator

Re: Trackable Link Not Working

That one does work right now -- can you verify that others are/aren't working at this moment?