Template Debug | Syntax Differences between 1.0 and 2.0 editors?

Highlighted
Level 5

Template Debug | Syntax Differences between 1.0 and 2.0 editors?

Hi all,

Recently I've started using 2 new email templates that are causing Marketo to behave strangely when we try using them in the Marketing Activities tab. Listed below are the links to the templates...

1.)

Login | Marketo

and...

2.)

Login | Marketo

Noted below (in bullet points) are the issues we're facing...

  • In Marketing Activities, when we try to create an email from scratch using either template above, a message appears that says "Cannot Load Email - There is a problem with this email. Please contact support@marketo.com."
  • We noticed that if you go into the template editor, make an "edit", and then save and close out template, then you can successfully create a new email from scratch in Marketing Activities (although there will be an additional template option with same name that will appear in the template drop-down menu box). We also don't want to have to edit the template in the design studio each time we need to use it.
  • We're able to use the template if we clone from an existing email (in marketing activities) that's been successfully created using that same template.

Has anybody experienced something similar? If you have any insights we would really appreciate it!

FYI - Marketo also tested these templates, and they indicated that this could be due to the code syntax in the email (response is below).

I am getting the same error when trying to open them in the editor. I also took the code from one of the templates and used it to create an email template in my testing instance. When using the Email 2.0 editor, the template works fine being used by new emails, but I get the same issue creating an email with it in the Email 1.0 editor.

One thing that may have caused this would be if this documentation - http://docs.marketo.com/display/public/DOCS/Email+Template+Syntax - was used when creating the HTML of that template, because that syntax is designed for the new 2.0 editor and can break the legacy 1.0 editor. Can you confirm if the syntax in the templates was taken from that documentation?

Thanks,

Tom

Tom Kerlin
3 REPLIES 3
Highlighted

Re: Template Debug | Syntax Differences between 1.0 and 2.0 editors?

Hi Tom,

We obviously cannot access templates in your Marketo instance. Provide screen shots or attach the code.

And, as you noticed, you absolutely cannot use email 2.0 syntax in an instance that is still in 1.0. This si surely the cause of you problem.

These may help:

Testing the email editor 2.0: Great features, a few glitches and the strong need for a v2.1

Upgrading to the new email editor 2.0: a recommended migration path

Greg

Highlighted
Level 5

Re: Template Debug | Syntax Differences between 1.0 and 2.0 editors?

Thanks Greg,

Please see attached!

Tom Kerlin
Highlighted

Re: Template Debug | Syntax Differences between 1.0 and 2.0 editors?

Hi Again,

No need to look at the code, as written above:

you absolutely cannot use email 2.0 syntax in an instance that is still in 1.0

-Greg