Success Date not being populated consistently

Highlighted
Anonymous
Not applicable

Success Date not being populated consistently

Hello Marketo Community pals,

Is anyone else experiencing a problem with the Success Date field not being populated consistently? We are noticing this right now and working through it with support, but thinking, "Are we the only ones?!".

We (Sarah SolbrigCam ConradSarah Solbrig noticed this issue while trying to pull February reporting. We are seeing this across several different Program types. We will see a Person who has a Program Success = Yes, but then Success Date = Not Available.

Support has a theory for why this is happening with our GTW synced Event Programs, but is now looking into why this would be happening in other types of Programs.

I'd love to hear if anyone else is experiencing this and what you are doing/have done about it.

Thanks!

- Sarah Luckow

P.S. Are you thinking "How would I know if I'm having this problem?" You can create a Program Membership Analysis Report RCE report that filters on Success Date = Not Available, Success Status = Yes and you could put Program Name as a row and Members as the Measure. If anyone shows up, I'd think you are having this problem.

9 REPLIES 9
Highlighted

Re: Success Date not being populated consistently

HI Sarah,

Interesting. Is this happening on webinars only?

I find the explanation from support a bit strange: my educated guess being that the success date would be set when a success status (e.g. attended) is reached, whatever the way it gets reached.

While support is investigating, you can create a smart campaign in you webinars that set the success date to {{system.date}}, using the "change program success flow step, with a "program status is changed" program.

-Greg

Highlighted
Anonymous
Not applicable

Re: Success Date not being populated consistently

Hi Greg,

The explanation I got was that if the webinar ends at 12:00 but the data gets sent over at 12:03 then those people attended after the webinar so don't really count as a success to the event. I can't manually update the event time in Marketo and it has to be done through our webinar partner.

However it is not just happening in event programs. It is happening in Default programs as well as nurture stream programs where there isn't a date/time to cause this conflict. This is more problematic as I know when our events happened but not when someone reached success in an on going program.

Sarah Solbrig

Highlighted
Anonymous
Not applicable

Re: Success Date not being populated consistently

Hi Greg,

Thanks for your suggestion for a workaround while we wait for support.

Highlighted
Anonymous
Not applicable

Re: Success Date not being populated consistently

If anyone needs help with the report, feel free to reach out.  I can help.

Sarah Solbrig

Highlighted
Level 10 - Champion Alumni

Re: Success Date not being populated consistently

Hi Sarah - I wonder if there's any relation to this issue: ISSUE: Trigger campaigns not firing for specific lead activity

Highlighted
Anonymous
Not applicable

Re: Success Date not being populated consistently

Dan - Maybe. I'd think that the success date field being populated is operational trigger. If your triggers aren't working it might be related. I'll be curious to what Marketo has to say about your case!

Highlighted

Re: Success Date not being populated consistently

Sarah - I'm experiencing a similar issue with webinars with ON24 syncing program successes into RCE. It looks like all webinars prior to February 9 have success properly recorded, but all recent webinars do not. (all of our webinar programs follow the exact same format)

It looks like it's an issue with both members and successes being incorrect and not a success date issue that I can tell. Any chance these could be related?

Highlighted
Anonymous
Not applicable

Re: Success Date not being populated consistently

Hi Aubrey,

I think our issues could absolutely be related. Thank you for sharing your experience. We also first noticed it in February, although we may have just not noticed prior. It's also interesting to know that you are experiencing this with a different webinar platform than we are currently using (GTW). Product Docs clearly state that the Success Date SHOULD be written when a Person reaches Success in a Program and that is what is not working for both of us.

We are still going around with support with no success. We are hoping to hear from a manager today. Have you had any luck discussing this with support?

This is majorly impacting our reporting so this is a big problem for us!

Katie Pope​, this is the support situation I've shared with you. It looks like we are not the only ones experiencing this situation.

Highlighted

Re: Success Date not being populated consistently

I updated success dates through batch programs last week and that seemed to do the trick. I guess it is the same issue after all!

I told support about it (and sent them a link to this thread), but so far no luck. In the meantime I'm moving to Grégoire Michel​'s suggestion and adding a trigger to update success date when status changes from On24.