SOLVED

Smart List Filter Not Catching All That Apply

Go to solution
Anonymous
Not applicable

Smart List Filter Not Catching All That Apply

I'm perplexed (again!)

I have the following Smart List: "Trigger = Clicks link in email" and "Filter = Opened Email"

filter-rule.PNG

(FWIW, my goal was to weed out the bogus lead scoring that happens when bots click all kinds of links. The bots don't even open the email, so I figured filtering out people who don't open email yet click links, thanks to the bots, would do this. There's some fallacy there.....but let's focus on this bit of weirdness below for now!)

So, we just sent this email and spot-checking the results I see the filter worked sometimes, but didn't work other times.

Example #1: This lead got credit for the link clicks even though they never opened the email. Filter should've caught this.

filter1.PNG

Example #2: This lead did not get credit for links clicked because they never actually opened the email (damn bots!). Filter worked here.

filter2.PNG

Sooooo.....the filter appears to have worked sometimes, but now always. Why?

I investigated if the Trigger constraints had anything to do with it. But they did not. For example, the constraint to not include "case-study"....clicks on a "case-study" link (with no email opened) sometimes got filtered out and sometimes didn't. So constraint isn't the issue. I'm at a loss.

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

The first step should be a Wait flow action. Drag that over and type 5 minutes in the blank spot.

The second step should be the Remove from Flow flow action, which you currently have as step 3.

Your step 3 and 4 should be the score changes that you currently have 1st and 2nd.

View solution in original post

9 REPLIES 9
Josh_Hill13
Level 10 - Champion Alumni

Re: Smart List Filter Not Catching All That Apply

First, Opens is notoriously unreliable as a method of filtering or triggering. I get what you are trying to do, but is that really necessary for even a scoring flow? Is the spam bot really causing that much of a problem?

Second, I'm not always convinced the clicks link trigger works 100% of the time, but the issue is more about Opened Email since few people will trigger this reliably. Have you tried the trigger when not downloading pix?

Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

Hi Josh -

Thanks for reply. But, yes, spam bots are causing a huge problem. Our sales-qualified leads are being populated by leads with hundreds of points because bots are clicking on every single link in every single email. In reality, these people haven't even opened a single email.

Seems the entire point of email marketing and lead scoring is made irrelevant by this major malfunction. I'm amazed Marketo doesn't have an easy solution for this that they can provide.

Chris_Morris1
Level 3

Re: Smart List Filter Not Catching All That Apply

Josh, is the measure of opens unreliable in all of email marketing, or just within Marketo's reporting?

Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

You may also want to try moving that filter into the flow instead of putting it in the smart list. Do a 5 minute wait and then a "if not opened email is X, remove from flow". I have occasionally found that to be more reliable.

Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

Thanks for the suggestion Kristen!

I've never done that before. I'm trying to set that up as you've indicated. But I don't see how to add the "wait 5 minutes." Also, not sure if how I set it up is correct. Does this look right to you to do what you were suggesting?

remove-from-flow.PNG

Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

The first step should be a Wait flow action. Drag that over and type 5 minutes in the blank spot.

The second step should be the Remove from Flow flow action, which you currently have as step 3.

Your step 3 and 4 should be the score changes that you currently have 1st and 2nd.

View solution in original post

Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

Ah, I didn't see that "Wait" option. Must've typoed my search or something.

But, wouldn't this mean any person who didn't open the email within 5 minutes is automatically removed? That would be removing a ton of legitimate leads who opened (and clicked) the email 10 minutes after sending, 30 minutes after, and so on.

What we need to do is an instance where there was NO open but YES clicks. Which means it's not human. But we don't want to eliminate humans who interacted a minute too late.

Or am i just misunderstanding Marketo's logic?

Thanks again!

Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

5 minutes after the person clicked, it checks to see if they opened the email also and if they didn't, it removes them. Your campaign only triggers for people who clicked (I assume based on your first screenshot).

You can extend the wait period if you want. But the likelihood of an open registering much more than 5 minutes after the click registered for that same person is pretty small. Opens is a notoriously unreliable metric anyway, since it relies on a pixel at the end of the email being loaded. If it hasn't been listed before the click, it likely won't be listed at all for that particular read of the email.

Anonymous
Not applicable

Re: Smart List Filter Not Catching All That Apply

Awesome! Thanks for the clarification. Yes, they only enter the flow if they clicked.