Setting Up Modules in a new email template

Anonymous
Not applicable

Setting Up Modules in a new email template

Hi all,

I'm developing new email template and I'm trying to create modules. When I run the validation, an error comes up about the id being invalid. At first I thought maybe I duplicated the id, but that was not the case. Below is the code for the table any suggestions would be greatly appreciated.

<table border="0" cellpadding="0" width="600" class="mktoModule"  id="header" mktoname="Header" align="center">

Thanks

Tags (2)
6 REPLIES 6
Level 10

Re: Setting Up Modules in a new email template

have you tried another ID? that might be reserved.

Anonymous
Not applicable

Re: Setting Up Modules in a new email template

Josh thank you for replying. I did change the id, but Marketo gave me the same error message.

Re: Setting Up Modules in a new email template

Hi Jeff,

Modules can only be set for <tr> tags, not tables.

The <tr> needs to belong  to a table with mktoContainer class.

You can only have one mktoContainer per template. See Email editor 2.0 is leaving room for a v2.1

-Greg

Re: Setting Up Modules in a new email template

The module can be a <table> if the container is a <td>

Re: Setting Up Modules in a new email template

My guess is you have another element with id="header" in the template...

Anonymous
Not applicable

Re: Setting Up Modules in a new email template

Thank you all for your help, I was able to get it to work based on a combination of all you replies.