SOLVED

Secure landing page issue

Go to solution
Highlighted

Secure landing page issue

We have a landing page - our first landing page.  When I view the link in different browsers, as well as mobile, I see that it's secure.  However, when I test the link with other people, they get the message that the page is not secure and they are not able to see the landing page.  I've checked the images and links and updated them all to be https, and then unapproved and reapproved the landing page. Even deactivated and reactivated the smart campaign.

 

Is there something else that I'm missing?  Why  can I see the secure page but nobody else?

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Community Moderator

Re: Secure landing page issue

Well, yes and no.... A 301 redirect with a long TTL, depending on how long it was in the wild, definitely wouldn't be good! It won't cure itself for those people who are affected, and you can't force it to. (Same with a long-lived but broken HSTS policy that was user-facing for more than a few minutes.)

 

Of course, as you say, if it truly only affects a couple of people that's fine. But hard to measure the impact in a martech context — you won't have people calling the Help Desk if an LP doesn't work!

View solution in original post

5 REPLIES 5
Highlighted
Level 10 - Community Moderator

Re: Secure landing page issue

You'll have to provide your URL.

Highlighted

Re: Secure landing page issue

Tags (1)
Highlighted
Level 10 - Community Moderator

Re: Secure landing page issue

That page is secure, and all of its assets are secure as well. So you set it up correctly.


That leaves open whether other people are actually navidating to the page as it currently stands. Is it possible that there was an old redirect rule that they have cached in their browser, for example, so they're being taken somewhere else?  Have you done a screenshare with any of them?

 

 

Highlighted

Re: Secure landing page issue

I have exactly the same issue in a couple of months ago.  You need to check all your images, links and redirections. If all of them are ok, and only 1 or 2 people have the issue, it is possibly caused by a browser/cookie setup. When I had a new laptop, I checked it was secure. So probably it is all good.

Tags (1)
Highlighted
Level 10 - Community Moderator

Re: Secure landing page issue

Well, yes and no.... A 301 redirect with a long TTL, depending on how long it was in the wild, definitely wouldn't be good! It won't cure itself for those people who are affected, and you can't force it to. (Same with a long-lived but broken HSTS policy that was user-facing for more than a few minutes.)

 

Of course, as you say, if it truly only affects a couple of people that's fine. But hard to measure the impact in a martech context — you won't have people calling the Help Desk if an LP doesn't work!

View solution in original post