SOLVED

Sample Emails not Being Received

Go to solution
Highlighted
Level 2

Sample Emails not Being Received

Hi Team,

Recently we aren't receiving any sample emails. There is no error shown in the course of send sample actions.

Does anyone facing the same issue?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 2

Re: Sample Emails not Being Received

Hi Guys,

It turns out to be that Microsoft was blocking all Marketo emails entering our mail servers as it was thought to be spoof mails. This happened when they updated the blacklist on March 29th.

Our IT team opened a case with MS and white-listed the all the Marketo domains.

Thanks for your support

VS

View solution in original post

16 REPLIES 16
Highlighted
Level 7

Re: Sample Emails not Being Received

There could be many factors at play. First thing to try - have you tried sending a sample to gmail or hotmail inboxes? check in the spam folder as well

Highlighted
Level 2

Re: Sample Emails not Being Received

Well, the samples sent to gmail and hotmail delivers just fine but not my work email and nothing in spam. IT team says, they didn't change any whit-listed IPs recently.

Highlighted
Level 7

Re: Sample Emails not Being Received

If Gmail or Hotmail can receive sample emails and it's not going into their spam, then there's nothing wrong with Marketo, or most likely your email template.

Next - send a "live test" to yourself. i.e. run a smart campaign where you send the email to yourself.

Highlighted
Level 6 - Champion

Re: Sample Emails not Being Received

Just because Gmail and Hotmail can receive the email and not the internal system doesn't mean much depending on how those test records are setup. Depending of what kind of token and how it's built, if (for example) the test records don't have all of the required fields to execute the velocity script, and then script doesn't have a proper #else to capture all users that fail the other script requirements, that could lead to some test records working while while others would not. This is why I also asked to send a production email as well, and wanted to understand what kind of script it is.

If they're standard lead fields and not a velocity script token, you're definitely right. Curious what is going on here!

Sent with BlackBerry Work (www.blackberry.com)

Highlighted
Level 7

Re: Sample Emails not Being Received

While good to be thorough, I was already 99% sure, based the OP's reply, that the issue is to related to their email server set up.

In addition, the OP wrote:

I never had to use the "PERSON" field for this action.

Suggesting all their tokens most likely had :default=values

Lastly, Marketo emails containing velocity tokens should always be tested through running a smart campaign and not send sample.

Highlighted
Level 2

Re: Sample Emails not Being Received

Nope, nothing showed up when used a smart campaign to send the email.

Highlighted
Level 6 - Champion

Re: Sample Emails not Being Received

Are their tokens in your from name/from email fields on the email asset? If yes, you MUST select a record in the "PERSON" field for the sample to mimic being sent from, otherwise the tokens themselves will populate and the SMTP servers will not release or deliver the message even though it is technically sent.

2019-04-01_10-39-54.jpg

Highlighted
Level 2

Re: Sample Emails not Being Received

Yes, we do have tokens in all the fields and it used to work just fine until last Friday. I never had to use the "PERSON" field for this action. I did try now, but no luck.

However, I still receive samples on my gmail even without the using the "PERSON" field, but not on my work email.

And system communication limit for samples count?

Highlighted
Level 6 - Champion

Re: Sample Emails not Being Received

What kind of token is in your name/email field? Is it a velocity script token (will start with {{my.___}}) or a {{lead.___}} token?

It is not my understanding that test emails count towards communication limits as they do not go through the production email compiler on the backend.

One thing to also test -- Find your record in lead database (the one with your work email where the sample isn't coming through), right click on the email and go to Marketing > Send Email and send a production version of the asset and see if that comes through. I have had issues, specifically when using tokens in from name/email, with test not working correctly.

2019-04-01_16-31-38.jpg

Please let me know if you're using a script token there, because I know of something that could be happening inside the script that could be causing this too!