SOLVED

Sample Emails not Being Received

Go to solution
Highlighted
Level 2

Re: Sample Emails not Being Received

Here is how the tokens look like in the address section and body section.

pastedImage_0.png pastedImage_1.png

I also tried sending the production email from the lead database but no luck. But the result shows "Delivered".

pastedImage_0.png

And it's not the issue with a particular email, but with all. Samples from the cloned or a newly created email with a starter template isn't working either.

I'm trying to send the sample email to myself to check the flow, my lead information is up to date in the database. Didn't work when tried sending to a colleague either

Highlighted
Level 6 - Champion

Re: Sample Emails not Being Received

Alright so they do look like velocity script {{.my}} tokens. In my experience with similar issues, I've had two outcomes I've dealt with:

  1. The sample email compiler was simply not working correctly. When you sent yourself the production version of the email, if this was the cause it would have been delivered as expected so this is likely not the cause. When this was my situation, Marketo's support team helped me to diagnose so a support ticket could help.
  2. The velocity script token code is not properly closed with an #else case in the logic. I don't know if this is the issue, but it's not impossible.

Other possibilities are that the issue could be with your internal mail server blocking the emails or marking them as SPAM, which I'd recommend Sandford's recommendation of having your IT team check the SMTP logs. The last reason I can think of is some kind of backend Marketo issue, which you'd have to submit a ticket for.

If you could share the code of the token we could rule out #2, but I understand if that's not something you'd like to do.

Good luck...

Highlighted
Level 10 - Community Moderator

Re: Sample Emails not Being Received

There's no communication limit at play here.

Bottom line, go back to your IT team and ask them to check their SMTP logs.

Highlighted
Level 2

Re: Sample Emails not Being Received

Any chance your recipient(s) have hit the system communication limit?

Highlighted

Re: Sample Emails not Being Received

This doesn't sound like the same issue, but we did have an error a while back with a few specific emails that we couldn't receive samples of. In that case, the email had corrupted somehow and the solution was to clone the email and try sending a sample again. In this case, the replacement email came through absolutely fine.

Highlighted

Re: Sample Emails not Being Received

Hi Viki,

I've had this problem many times before! I've also spoken to support about it before and they couldn't come up with a concrete reason as to why. If it's not an IT server issue or token issue, something in the email is likely corrupted. Usually when this has happened to me, I've had to go through and create the email again from scratch. Not a great solution, but that's what's helped me in the past!

Highlighted
Level 2

Re: Sample Emails not Being Received

Hi Guys,

It turns out to be that Microsoft was blocking all Marketo emails entering our mail servers as it was thought to be spoof mails. This happened when they updated the blacklist on March 29th.

Our IT team opened a case with MS and white-listed the all the Marketo domains.

Thanks for your support

VS

View solution in original post