SOLVED

Salesforce account updates do not reflect in Marketo

Go to solution
Highlighted
Level 2

Salesforce account updates do not reflect in Marketo

Hi all,

We are seeing some massive discrepancies between SFDC and Marketo. We see it mainly (maybe only) at the account level. It seems that the first time the information comes in from SFDC to Marketo, the account data is updated but any further updates do not sync into Marketo (so for example, we don't see once an account becomes a paying customer since this update did not come to Marketo.)

 

We tried to manually update some fields on SF for some contacts, leads, and accounts - Only leads and contacts information was also updated in Marketo. The account information was not.

 

We're not sure what causes it - Is it something in the Salesforce objects sync section? Maybe we're not syncing the right objects?

Any one-time solution isn't sufficient since we're looking to fix that problem once and for all. No fields are blocked from updates.

 

What do you think?

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 7

Re: Salesforce account updates do not reflect in Marketo

most common cause is field security settings in SFDC for your sync user. check your sync user's permission sets and field security access for all account fields. make sure it has write access.

View solution in original post

3 REPLIES 3
Highlighted

Re: Salesforce account updates do not reflect in Marketo

Hi @ItayOved,

 

Did you check the Notification tab to see what are the Sync errors that are specified there?

Ronen Wasserman
Highlighted
Level 2

Re: Salesforce account updates do not reflect in Marketo

Hi Ronen,

Yup, I do see notifications that are "Marketo is unable to update Lead in Salesforce." (which is another issue that we have - though we just had a breakthrough!), but this is more of a "Salesforce is unable to update Lead in Marketo." type of issue - which I do not see any notification on that.

Highlighted
Level 7

Re: Salesforce account updates do not reflect in Marketo

most common cause is field security settings in SFDC for your sync user. check your sync user's permission sets and field security access for all account fields. make sure it has write access.

View solution in original post