SOLVED

Rendered_Email_Velocity_Error_Area_?! error without velocity scripting???

Go to solution
Jared_Kimball2
Level 3

Rendered_Email_Velocity_Error_Area_?! error without velocity scripting???

Hi community,

Our brand managers keep getting an error whenever they try to save a brand new template we created.

We are able to save and approve the template, but whenever a brand manager tries to create, edit and save an email with that template they keep getting:

Rendered_Email_Velocity_Error_Area_?!

Rendered_Email_Velocity_Error_Area_.png

I can't figure out for the life of me how to solve this.

I saw on another thread that there could be an error with a "#" or "?" but I'm not sure where to look exactly.

Any suggestions? Sanford Whiteman

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
SanfordWhiteman
Level 10 - Community Moderator

Re: Rendered_Email_Velocity_Error_Area_?! error without velocity scripting???

Bet this is actually happening on the Text side.

If you have a mktoVariable defined that you're using as an <a href>, that causes a break on the text side since variables don't work in the text version. (Normally variables don't cause an error, they just are blank, but links are an exception.)

Solve it by adding this to your <head>:

<!--

#set( $link = "${link}" )

-->

where link is the mktoVariable name.

View solution in original post

2 REPLIES 2
SanfordWhiteman
Level 10 - Community Moderator

Re: Rendered_Email_Velocity_Error_Area_?! error without velocity scripting???

Bet this is actually happening on the Text side.

If you have a mktoVariable defined that you're using as an <a href>, that causes a break on the text side since variables don't work in the text version. (Normally variables don't cause an error, they just are blank, but links are an exception.)

Solve it by adding this to your <head>:

<!--

#set( $link = "${link}" )

-->

where link is the mktoVariable name.

View solution in original post

Jared_Kimball2
Level 3

Re: Rendered_Email_Velocity_Error_Area_?! error without velocity scripting???

That worked perfectly. Thank you!!!