Question about landing pages and LinkedIn

Anonymous
Not applicable

Question about landing pages and LinkedIn

I created a Marketo landing page and am trying to use the link on LinkedIn and for some reason it is pulling in copy and an image from another program. I checked and the meta tags are correct so I am not sure where this info is living and how to change it. I saved and approved the landing page and it is still showing up. I searched the Marketo help pages and can’t find anything there. Any thoughts?

Tags (2)
5 REPLIES 5
Jim_Thao7
Level 8

Re: Question about landing pages and LinkedIn

Links to the pages and clarification on what you see vs. what you expect to see would help out a lot here.

Anonymous
Not applicable

Re: Question about landing pages and LinkedIn

Thats odd, can you send over the html?

Courtney_Grimes
Level 10

Re: Question about landing pages and LinkedIn

Hi Jennifer,

Just a reminder that LinkedIn caches its Open Graph tags in order to save resources—and as a result can show older versions of what you see. Try adding a parameter to the URL or changing the path to see the updated version.

Anonymous
Not applicable

Re: Question about landing pages and LinkedIn

Thanks this is really helpful for a confusing problem

Jessica_Kao3
Level 8 - Champion

Re: Question about landing pages and LinkedIn

I've run into this a lot before.  Linkedin will keep it cached for up to a week.  One way around it is to clone the LP and try again as a last resort.  Sometimes changing the url works sometimes it doesn't.