Progressive profiling - not working

Highlighted

Progressive profiling - not working

Hi Marketo community!

I have a confusing issue with a form. I have enable progressive profiling for that form where two fields show up as the one before is filled. The fields are -  first name, last name, job title and company. I have embedded this form inside a website. Here is what happens when I run tests with fake leads:

  • First name filled, last name empty - when you come back to the page the other two fields are visible (last name & job title)
  • Last name filled - when you come back nothing happens.
    Ideal behavior should be for the other two fields to be visible (job title & company)
7 REPLIES 7
Highlighted
Level 10 - Community Moderator

Re: Progressive profiling - not working

That's not the way ProgPro works. It shows up to a certain number of empty fields. If you want to re-show *non-empty* fields (bit circular IMO) then you need to implement that logic using JS.

Highlighted

Re: Progressive profiling - not working

Hello,

So what you mean to say is that the form only pops up once again to show all the empty fields? I'm confused on what you mean by non-empty fields because progressing profiling does not show them and neither do I want it to.

I wish for the form to show only the empty fields after the filled field.

Thank you!

Highlighted
Level 10 - Community Moderator

Re: Progressive profiling - not working

I wish for the form to show only the empty fields after the filled field.

Progressive Profiling shows up to N empty fields in the ProgPro block each time you view the form.

Say you have 4 fields in the block (Field A, Field B, Field C, Field D) and the form is set to show 2 empty fields. On the first form view, you fill out only Field A. The next form view will show Field B and Field C

Without a link to your page there's nothing more i can do.

Highlighted

Re: Progressive profiling - not working

Hello again,

You are right and I have set the form to show two empty fields. Once I fill field A, field B and field C were reflected on the form.

The second time I filled field B and came back to the page. The problem is - the form itself did not pop up. I'm not sure if this is a marketo issue or the webpage issue.

I hope I'm making sense ?

Thank you.

Highlighted
Level 10 - Community Moderator

Re: Progressive profiling - not working

You'd have to provide a link.

ProgPro doesn't have a mode where the whole form is hidden.

Highlighted
Level 2

Re: Progressive profiling - not working

@SanfordWhiteman can I ask you for help with progressive profiling as well? 

Highlighted
Level 10 - Community Moderator

Re: Progressive profiling - not working

You could open a new thread in Products: https://nation.marketo.com/t5/Products/ct-p/products...