Problems rendering forms after SSL upgrade?

Kevin_Keefe
Level 1

Problems rendering forms after SSL upgrade?

Hi there everyone,

We recently upgraded our website to be secured using an SSL Certificate. Shortly thereafter, SOME of my Marketo forms that I have on the site are not rendering.

I haven't tested multiple browsers but it's happening in Chrome and Safari to the best of my knowledge.

The documentation I am able to find from Marketo all relates to landing page security but not forms. Does anyone else experience this?

Very grateful!

3 REPLIES 3
Steven_Vanderb3
Marketo Employee

Re: Problems rendering forms after SSL upgrade?

There's two reasons this could happen that come immediately to mind:

1.  You have forms iframed onto a Marketo landing page.

2.  You call the form embed code JS using your landing page domain rather than the default https://app-xxx.marketo.com/js/forms2/js/forms2.min.js path.

In both scenarios you would need to secure your Marketo landing page domains.  If you provide a link to an example of where this is happening then we could get a better idea of the answer.

Kevin_Keefe
Level 1

Re: Problems rendering forms after SSL upgrade?

Steve,

It looks like I had the latter issue.

As a band-aid, I was able to copy a new embed code from the form which did not have that address in there, but from what I understand, we are not going to have an option but to do the Marketo required securing of the site eventually right?

Kevin Keefe

Marketing Manager

Office: 315-434-9787 x1123

kkeefe@cadimensions.com<mailto:kkeefe@cadimensions.com>

<http://www.cadimensions.com/>

CADimensions, Inc.

6310 Fly Road | East Syracuse | NY | 13057 | USA

www.cadimensions.com<http://www.cadimensions.com/>

SanfordWhiteman
Level 10 - Community Moderator

Re: Problems rendering forms after SSL upgrade?

Yes, if you want to ensure your forms work in the widest range of scenarios (i.e. anti-tracking features and plugins broadly blocking all assets at marketo.com, even those not directly implicated in tracking) you need to use one of your custom domains, ergo that domain needs to be secure.