SOLVED

Original Referrer field not syncing to SFDC

Go to solution
Highlighted
Anonymous
Not applicable

Original Referrer field not syncing to SFDC

HI, we are having trouble getting the Original Referrer field to sync to it's counterpart in Salesforce. We followed the process outlined in the support docs to create the field in SFDC, and it was supposed to populate automatically, but something went wrong. In the aftermath, I think we tried deleting the SFDC field and creating a new Original Referrer field, but that won't sync either. I think we need to start over somehow, but we're not able to delete or reset the Orig Referrer fields in Marketo. What's the best way to proceed?

Thx,
Colin

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Original Referrer field not syncing to SFDC

Hi Colin,

Please make the question as answered for future reference.

-Greg

View solution in original post

5 REPLIES 5
Highlighted

Re: Original Referrer field not syncing to SFDC

Hi Colin,

Start with checking how the field is created in SFDC (provide a screenshot if you want us to get a second glance ) and make sure that the Marketo user profile has the right on this field.

-Greg

Highlighted
Anonymous
Not applicable

Re: Original Referrer field not syncing to SFDC

Hi Gregoire,

Here iare a couple of screenshots of the fields in SFDC:

pastedImage_0.png

pastedImage_1.png

In Marketo, this 'Original Referrer New' field seems to have been created, but it is currently not populating. It is mapped as such:

pastedImage_2.png

The old 'Original Referrer' field in Marketo is populating, but did not seem to map properly to the new SFDC field as it was supposed to according to the instructions we followed. Here are the current mappings in Marketo:

pastedImage_4.png

Does the 'Original Referrer New' field in SFDC have to be a URL field type? Any other ideas?

Tx!

Colin

Highlighted

Re: Original Referrer field not syncing to SFDC

HI Colin,

Do not look at the "mappings" section. Look at the Field themselves.

You mapping is wrong on Marketo side. You should only have 1 "Original referrer" field and it should be mapped with the mkto71 fields:

pastedImage_0.png

pastedImage_1.png

This means that Marketo it still updating the old, non sync'ed fields.

You will have to call support in.

And while you are there, you should check the other mkto71 fields.

-Greg

Highlighted
Anonymous
Not applicable

Re: Original Referrer field not syncing to SFDC

I figured as much. Thanks Gregoire.

Highlighted

Re: Original Referrer field not syncing to SFDC

Hi Colin,

Please make the question as answered for future reference.

-Greg

View solution in original post