SOLVED

New images uploaded, wrong image sent

Go to solution
Highlighted
Level 2

New images uploaded, wrong image sent

We've experience this issue in the past, where we upload new versions of jpegs or gifs into design studio and replace them in the email. We approved & sent tests and the correct images were there. However, when the email went out this morning, the old images were in the email. Just to make sure, in design studio I checked the new image and it says that it was used for this mornings email. Can this be fixed?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Community Moderator

Re: New images uploaded, wrong image sent

Really, you've already proved it with these symptoms.

Change the image URL by adding a ?1234 (or any random string) to the query string and send again, that'll confirm for sure.

View solution in original post

6 REPLIES 6
Highlighted
Level 7 - Champion Alumni

Re: New images uploaded, wrong image sent

Go straight to Marketo support with that one. If you have something where the Marketo software itself seems to be misbehaving, they are your best bet for figuring out why. You are correct, the image should have just been replaced.

Highlighted
Level 10 - Community Moderator

Re: New images uploaded, wrong image sent

Are you sure (how are you testing?) that you are not simply seeing a cached image? Mail clients are free to cache images regardless of whether they've been replaced on the server. So if you've sent the email to yourself with the "old" images it's quite possible to see those same images when you resend and read in the same mail client. Obviously across mail clients who have never seen the URL before, there would be no caching in play.

Highlighted
Level 2

Re: New images uploaded, wrong image sent

I test my emails by sending samples to myself then proofing with the team. How can I find out if this is a cached image?

Highlighted
Level 10 - Community Moderator

Re: New images uploaded, wrong image sent

Really, you've already proved it with these symptoms.

Change the image URL by adding a ?1234 (or any random string) to the query string and send again, that'll confirm for sure.

View solution in original post

Highlighted
Level 2

Re: New images uploaded, wrong image sent

Ok it worked! How do I prevent this from happening in the future? Just keep adding a query string to each image url? This is a random occurrence. Is it possible that something in the url triggered marketo or the server to cache the image?

Highlighted
Level 10 - Community Moderator

Re: New images uploaded, wrong image sent

It isn't anything about the URL that's causing it. This is happening all the time in the real world, people just don't realize it!

You can have a {{my.embeddedAssetsVersion}} token that you increment as necessary and append that to all image URLs.