SOLVED

New Leads - Missing Referrers?

Go to solution
Highlighted

New Leads - Missing Referrers?

I have smart campaigns built to assign a lead source /lead source detail for each new lead and one of the combinations is direct / direct-url. I also have an alert setup to email me anytime this happens because the cases of that being the lead source should be minimal. When I get the alerts, I check the activity log for the lead to ensure that campaign worked as expected. Although the campaign is working as expected, I feel there is information missing from the web page visits.

Example

A new lead is created when they fill out a form on this page ( Drug-Nutrient Interaction Checker | Integrative Therapeutics ) and this page was the first page of their visit with no referring website/search engine. This page is 3 folders deep so there is no chance that someone would just happen to type it in. See below for the activity log and new lead details.

Is there a reason this may be happening?

mkto-lead-missing-referrer.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Level 10 - Community Moderator

Re: New Leads - Missing Referrers?

There are a few ways to get a pageview without a referrer value (that's the true HTTP referrer/JS document.referrer). It's not just direct entry and bookmarks.

Another common cause is if the source page is running https: and (as I see is the case with your site) the target page is running http:.  The default behavior is for no referrer to be sent in this setup. Modern browsers do support technology that -- if also implemented on the source page -- allows a referrer to still be relayed from secure to insecure pages. But if I simply paste your link on my blog running https, you won't know where people came from. We strongly recommend running SSL on Marketo LPs for this reason (and others!).

I can't say exactly where this single pageview came from based on the info provided, but the occasional missing referrer is to be expected.

View solution in original post

4 REPLIES 4
Highlighted
Level 10 - Community Moderator

Re: New Leads - Missing Referrers?

There are a few ways to get a pageview without a referrer value (that's the true HTTP referrer/JS document.referrer). It's not just direct entry and bookmarks.

Another common cause is if the source page is running https: and (as I see is the case with your site) the target page is running http:.  The default behavior is for no referrer to be sent in this setup. Modern browsers do support technology that -- if also implemented on the source page -- allows a referrer to still be relayed from secure to insecure pages. But if I simply paste your link on my blog running https, you won't know where people came from. We strongly recommend running SSL on Marketo LPs for this reason (and others!).

I can't say exactly where this single pageview came from based on the info provided, but the occasional missing referrer is to be expected.

View solution in original post

Highlighted

Re: New Leads - Missing Referrers?

Thank you Sanford!

This helps alot and I will be reaching out to our IT team about the certificate.

Highlighted

Re: New Leads - Missing Referrers?

Hey Jason, that's exactly the problem... Marketo will charge you a 1x fee of ~$4k and make you wait ~3 weeks for the update, but then you'll have the info back.

Highlighted

Re: New Leads - Missing Referrers?

Sorry.. then the info will start to populate again. No backfill will occur.