My 'visited web page' number is not quite right?

Highlighted

My 'visited web page' number is not quite right?

I made a smart campaign with the listening  trigger 'clicks link in email' with the 2 emails I wanted specified and no other constraints.  In addition, as a filter I added 'visited web page' and selected the Marketo created LP from the dropdown and with date of activity between 10/22/2020 and 11/6/2020  (the lp was not active until 10/21).

I am only seeing very few people showing up and in my test user accounts only one showed up, even though I clicked the link in emails for both and left the Landing page open for a while before I closed it.   Any idea what has to happen in this scenario for it count everyone?

In contrast, I created another smart campaign with just filter of clicked link in email with the 2 emails I wanted specified and constraint of link contains and added in the Marketo LP link (it was linked in both emails) w/o the https:// 
ex: pages.scilearn.com/Webinar_2020-Dyslexia-Update 
For this I got 352 clicked and for the first trigger with the visits webpage I only got 51. But both would ultimately direct them to the same landing page. What's going on with the difference in numbers??

5 REPLIES 5
Highlighted
Level 10 - Community Moderator

Re: My 'visited web page' number is not quite right?

That link doesn't actually work, so impossible to check it out further.

 

I do notice that your main corp site isn't loading Munchkin, which is surprising.

Highlighted

Re: My 'visited web page' number is not quite right?

Oh yes, I didn't give the full url on here. It's https://pages.scilearn.com/Webinar_2020-Dyslexia-Update-New-Science-and-Solutions.html 
but when I used the filter in the smart campaign it's not the URL I used, I used the LP name that I gave it in marketo and that popped up on the dropdown.

Highlighted
Level 10 - Community Moderator

Re: My 'visited web page' number is not quite right?

That's a Marketo LP loading Munchkin in the built-in (automatically injected) way. Shouldn't be any problem logging pageviews. Which makes me think the problem is in your links themselves not including the critical mkt_tok query param.

Highlighted

Re: My 'visited web page' number is not quite right?

how would I check and fix that?
It was using Web page is and selecting my approved LP option that was giving me a smaller number. 

Highlighted
Level 10 - Community Moderator

Re: My 'visited web page' number is not quite right?

You'd have to show a lot more about how your links are constructed and the real-world results.

 

If it happens that you don't have mkt_tok added but do have the link tracked, then you'll see Clicked Email but not Visited Web Page. Of course the more common reason is that people are blocking cookies.