Modules Tab Grayed out

Highlighted

Modules Tab Grayed out

Hey there --

I inherited a project for a template my company is using and the "modules" tab in the back end is grayed out (this is my first real experience with Marketo). Previously, content editors have selected modules they want to use by deleting unused modules (all are present in the template when it loads), but once a module is deleted it cannot be added back because it can't be dragged/dropped from the module tab -- Dropbox - Screenshot 2019-01-09 11.49.41.png

Has anyone else experienced this issue? Is there a marketo attribute I'm missing?

Thanks so much!

6 REPLIES 6
Highlighted
Level 5

Re: Modules Tab Grayed out

Kind of hard to troubleshoot with the details provided.

- If you click on the email within the Marketo UI, does it say it's connected to a template still?

mkto-template.png

- Other than that, maybe scan the code and ensure:  mktoName, mktoModule,  are set / unique and look for missing quotes / coding errors.

Highlighted

Re: Modules Tab Grayed out

There is no template Dropbox - Screenshot 2019-01-09 12.55.10.png

Should there be? What does that indicate?

Sorry things are lean on the details - happy to provide whatever will help!

Highlighted
Level 5

Re: Modules Tab Grayed out

It would appear at some point, someone clicked 'Edit Code' on the 'Email' which then dis-associates it from the 'Template' code which is used for the layout / modules function.

I would try creating a fresh email that uses the template to see if the Modules work.  

If the Modules do work in the new Email - The template code is ok and the issue is with that particular email and caused from bad process for code changes

If the Modules do not work in the new Email - There may be an existing issue with the template code that needs to be remedied (this could be why someone edited the code in the email to begin with)

hope it helps!

Highlighted

Re: Modules Tab Grayed out

Mark, thank you so much for your help!

Your suspicion was right - somewhere along the line there was no "template" applied to the emails themselves - knowledge lost somewhere along the way apparently.

Anyways, problem solved, thanks again!

Highlighted
Level 5

Re: Modules Tab Grayed out

Happy to hear it's solved and was a quick fix!  

Highlighted
Level 1

Re: Modules Tab Grayed out

Thank you, simply Approving the template fixed this issue for me.