Marketo System Date Time not matching in different locations

Highlighted

Marketo System Date Time not matching in different locations

We are noticing that when Marketo is stamping a Date and Time to a SFDC field the time is showing up inconsistent in different tools.  We are set to EST, but if you see the lead below the date time was stamped in the flow as 12:12 but in the Activity log it was stamped as 1:12.  Also inside of PowerBI the time for this field on this lead is 4:12.  Is there a way to stamp Time Zone with Date and Time to ensure Date and Time is consistent across the board, even to APIs?

Untitled.png

2 REPLIES 2
Highlighted
Level 6 - Champion Alumni

Re: Marketo System Date Time not matching in different locations

Hey Robert,

I would double check the settings for timezone of all your tools. My assumption is that the field is being translated from its timezone (marketo instance time) into the system time of the tool it's being pushed into. Another note, Marketo will show the activity log based on the timezone of the user in the activity log (so time you see in Activity Log may not be what Marketo is pushing to other tools). So be sure to check both your instance timezone, and your timezone as a user. May help you identify what's going on here.

Hope this helps!

Highlighted
Level 6 - Champion Alumni

Re: Marketo System Date Time not matching in different locations

Based on this article, Marketo will pass times including the timezone. So again, this feels like the times are all the same but timezones of the tools are not all in alignment.

http://developers.marketo.com/rest-api/lead-database/fields/field-types/