Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Highlighted
Level 2

Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Hi folks,

I recently uncovered this error in our system, and haven't been able to figure out why it is occurring. I have checked our field mappings, but that seems fine. This error does not occur on every record, so I don't understand why it happens on some of them. I have manually updated some records by copy/pasting the Company from the Lead in Salesforce over to the Lead record in Marketo. Silly. Not sure how to fix this via a batch either.... Would love any tips or suggestions.

The error:

REQUIRED_FIELD_MISSING: Required fields are missing: [Company]\n

Tags (2)
9 REPLIES 9
Highlighted

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Loren,

It is quite possible you are trying to sync over people in Marketo that do not have a Company Name on their record. If you create a person in Marketo, the company name is not required, but if you try to sync that person to SFDC, you will need to populate that field beforehand.

Highlighted
Level 7

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

You can set a default company name for empty values by going to Admin => Salesforce => Edit sync options

pastedImage_0.png

Highlighted
Level 2

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Thanks Jay and Devraj. We do have those settings on - screenshot below.

What I see often is that there's a Company entered in Salesforce but it doesn't sync into Marketo.

Screen Shot 2018-12-04 at 6.35.52 PM.png

Highlighted
Level 7

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Are you saying your sales people are creating Account records and Lead/Contact records separately?

In that case a lead needs to be converted and added as a contact under the account record.

Highlighted
Level 2 - Champion Alumni

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Are the records originating from SFDC or MKTO?

Highlighted

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Good point Ashley, sales reps may not be entering company in some cases, it gets sync'd to marketo but can't sync back to SFDC.

Highlighted
Level 2

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

In these cases there is a Company value showing on the Lead record in Salesforce. So that's not the issue. Mostly these records are coming from Marketo - marketo form fills.

Highlighted
Level 5

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Hi all,

 

I hope all is well. We're experiencing something similar in our instance where we keep getting the following error details:

 

"Salesforce Sync Error

Why: Marketo is unable to update Lead in Salesforce.

Error details:
REQUIRED_FIELD_MISSING: Required fields are missing: [Company]"

 

It's strange because it's something that just started occurring for us but we've always had a "Default person last name" set as "Unknown" and a "Default person company" set as "Unknown" in the Sync Options tab (under Salesforce integration).

 

If we have the default values set up then the errors can't be coming from the Marketo side right? 

 

Thanks,

Tom

Tom Kerlin
Highlighted
Level 2

Re: Marketo - Salesforce Sync Issue "Required fields are missing: [Company]/n"

Hey Tom,

 

We are experiencing something similar. Were you able to troubleshoot on the SFDC and find a resolution?


Brad