Marketo Salesforce Campaigns Syncing Issue

Highlighted

Marketo Salesforce Campaigns Syncing Issue

"Salesforce campaigns are not syncing into Marketo. When we try to "add to SFDC campaign", only a few campaigns show, while there are dozens available in Salesforce. We have tested a few times and cannot resolve." How do we do it? Also, Is the campaign creation in Marketo to Salesforce one way or it happens both ways?

4 REPLIES 4
Highlighted
Level 10 - Champion Alumni

Re: Marketo Salesforce Campaigns Syncing Issue

If your user profile for Marketo User allows R/W of SFDC Campaigns, you can enable this in Admin > SFDC. Then the SFDC Campaigns will sync.

Yes, you can use the Program Sync to SFDC Campaign feature to Create New SFDC Campaign, but I don't recommend a direct Program to SFDC Campaign sync. There are 100 threads on why but it comes down to control of lead flow.

Can you ask your SFDC Admin to review the user permissions with you and Marketo Support? Since you didn't tell us about what steps you took, not sure I can offer more.

Highlighted
Level 10 - Champion Alumni

Re: Marketo Salesforce Campaigns Syncing Issue

Also, the SFDC Campaign must be Active=T to be seen and used by Marketo.

Highlighted

Re: Marketo Salesforce Campaigns Syncing Issue

First thing I'd check is the Marketo Sync user permissions in Salesforce. If the User has access to a few campaigns but not all (and you have checked whether the campaigns are active) chances are your 'Organization Wide Defaults' for campaigns in Salesforce are set to 'private' which means the Marketo User can only 'see' campaigns created by the Sync User itself, not campaigns created by others. Does the Marketo Sync User have an administrator profile in Salesforce?

Highlighted

Re: Marketo Salesforce Campaigns Syncing Issue

HI Inbound Team NetElixir​,

If you have tried the above steps try searching for the SFDC campaign by only inputing some of the name in the search field.  I noticed a few weeks ago that when I put the full name in exactly as it was in Salesforce it couldn't find it, but when I only put in half the name it would appear in the prompting/auto complete section that appears below and I could select it there.

Thanks,

Gerard