SOLVED

Marketo Landing Pages not Viewable on Internal Network

Go to solution
Highlighted

Marketo Landing Pages not Viewable on Internal Network

Was wondering if anyone had solutions or similar issues viewing landing pages externally vs. internally on their company network?  

I currently cannot view a marketo landing page when I am connected to my internal network.  I get the following error.  The error occurs regardless of browser (IE/Firefox).
 



Oops! Google Chrome could not connect to cname.domain.com

Externally, I do not have these issues and the pages load fine displaying the CSS correctly.  Oringally we were only having issues loading the CSS, but now we cannot load the pages at all.    

Our internal and external settings are configured the same way so that our cname.companydomain.com points to our accountstring.mktoweb.com.  Any ideas as to what is going on?  

Thanks,

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Marketo Employee

Re: Marketo Landing Pages not Viewable on Internal Network

Hey Michael,

In addition to wat Josh noted, you may need to flush your local DNS at the router level.  You can see if the CNAME entry is currently available by opening up a local commandline and typing the following:

nslookup
set type=txt
[domain you're trying to reach]

This will query your local DNS to see if the entry is available.  If it's there and is pointing to your Marketo instances account URL, then it s not explicitly a DNS issue, and may be related to other netowkr restrictions in place.

View solution in original post

3 REPLIES 3
Highlighted
Level 10 - Champion Alumni

Re: Marketo Landing Pages not Viewable on Internal Network

I would check with your internal IT team. It sounds like they did not permit your internal network to redirect properly to the cname.

You could also log a Marketo Support ticket to see if they have anything useful to say.
Highlighted
Anonymous
Not applicable

Re: Marketo Landing Pages not Viewable on Internal Network

You might have IT restrictions to load NOT https pages. You might need to enable SSL for your pages.
Highlighted
Marketo Employee

Re: Marketo Landing Pages not Viewable on Internal Network

Hey Michael,

In addition to wat Josh noted, you may need to flush your local DNS at the router level.  You can see if the CNAME entry is currently available by opening up a local commandline and typing the following:

nslookup
set type=txt
[domain you're trying to reach]

This will query your local DNS to see if the entry is available.  If it's there and is pointing to your Marketo instances account URL, then it s not explicitly a DNS issue, and may be related to other netowkr restrictions in place.

View solution in original post