SOLVED

Marketo-Dynamics sync setup

Go to solution

Marketo-Dynamics sync setup

Hello everyone,

We are having an issue with Marketo-Dynamics OOB integration setup. We simply cannot get it to work. We followed the instructions for integration on Marketo docs website (installing solution, setting up a user, etc...).

Error we are getting during validation is invalid username or password. Which makes little sense because when we use the same credentials to login directly to Dynamics everything is OK.

Only thing we are getting from Marketo support is to check the credentials, but the credentials are OK obviously. Setup is Dynamics v9 online and Marketo. The client has ADFS as authentication layer (integrated with Office 365/Azure). As mentioned, we installed Mkto solutions, gave user roles etc.

Also, we have set up the App registration on Azure AD. Interestingly when we use the ClientId in validation we get Invalid URL, without it we get invalid username or password. Not really sure what is the purpose of this registration, because we are not using SecretId anywhere. Did anyone have similar issues?

To make things worse, the initial sync is in progress and it is stuck.

Thank you,

Antonio

1 ACCEPTED SOLUTION

Accepted Solutions
Abhinav_saini
Level 3

Re: Marketo-Dynamics sync setup

Hi Tony,

The same issue we were facing and have resolved it by disabling the MFA at dynamics end and it works for me. 

Check with your dynamics team if MFA is enabled or not. (Multi factor authentication)

Abhinav Saini

View solution in original post

7 REPLIES 7
Lindsay_Khan
Level 1

Re: Marketo-Dynamics sync setup

Are you using the Organization Service URL: https://docs.marketo.com/display/public/DOCS/Fix+Dynamics+Validation+Sync+Issues#FixDynamicsValidati... (there's a screenshot in there). 

David_Vogel1
Level 1

Re: Marketo-Dynamics sync setup

Hi,

Do you find a solution for your problem?

 

We are try co connect Dynamics and Marketo with an App registration User. We get the error "Invalid User or Passwort"

 

Abhinav_saini
Level 3

Re: Marketo-Dynamics sync setup

Did u get the solution ?

I am facing same issue while connecting both tools. However, I am able to login dynamics 365 but in Marketo it is showing "username & password invalid".

Not sure what to do......

Abhinav Saini
Abhinav_saini
Level 3

Re: Marketo-Dynamics sync setup

It was because of multi factor authentication at dynamics end.  We disabled the MFA and able to sync dynamics and Marketo smoothly. 

Abhinav Saini
TongX
Level 1

Re: Marketo-Dynamics sync setup

Hey David

I'm facing the same problem...did you eventually solve yours and how did you do that?

 

appreciate the sharing!

Abhinav_saini
Level 3

Re: Marketo-Dynamics sync setup

Hi Tony,

The same issue we were facing and have resolved it by disabling the MFA at dynamics end and it works for me. 

Check with your dynamics team if MFA is enabled or not. (Multi factor authentication)

Abhinav Saini

View solution in original post

Jamesddls
Level 1

Re: Marketo-Dynamics sync setup

Hey Everyone,

 

I am trying to find out what the real error here is too. I am confident I do not have MFA on for the user. The Permissions are set and the details are correct.