Marketo Bulk Import to Static Lists - Issues / Bugs

Highlighted
Level 2

Marketo Bulk Import to Static Lists - Issues / Bugs

Hi, 

When performing bulk imports to static lists there are a couple issues that my team is running into: 

Issue #1

Background: On a bulk import to a static list using a lookupField (where the lookupField is the marketo lead id itself)

Problem: if for some reason the marketo lead was deleted in marketo prior to the attempted import, the bulk import will get stuck in 'Importing' status fo an exceedingly long time (can take up to 10 minutes before inevitably finishing with 0 records imported) 

 When this import finally completes i have no warnings or failures to recognize something was wrong with the input list, it simply returns that nothing is wrong. It would be nice to get the lead ids that were not found, so that i may "regenerate" those marketo lead records (import w/o the lookupField)

Issue #2:
Background: bulk import of static lists issue a batch id that is always the same as the static list itself. 

Problem: When polling the status of the batch id, in the rows for "message, numOfRowsFailed, numOfRowsWithWarning, numOfLeadsProcessed" i actually am seeing those columns returned for the previous import, completely unrelated to the import that is currently in progress. (Only the status is valid). 



Personal Background:
I represent a healthcare CRM that mantains API integrations for several marketo instances and marketo clients (10). We need to mantain several list syncs from our clients databases, but be resilient when our client does something bad, like delete a lead.

Tags (2)